cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mjawa
Regular Visitor

Display Form Record based on value from a Gallery

Howdy, 

 

I'm working on an inventory PowerApp and I'd like to have a screen that has three items - a gallery of users (UserGallery), a display form with the record from the selected user (UserInfo), and another display from that shows the details of the device that's assigned to the user (StationInfo). The information for this is on two Sharepoint lists - one for Users and another for Assets. The User list has a lookup column that picks the Asset by the title name. 

 

I've tried a lookup, but I get an error with the equal size not being valid. Is this even possible or do have the lists built incorrectly for this to work? Thanks in advance for the help. 

11 REPLIES 11
kidvallejo
Helper III
Helper III

Can you show me the vlookup you have tried?

So based on the following working, 

LookUp(Assets, Title = "Station 94")

 

I tried

LookUp(Assets, Title = UserGallery.Selected.Computer) &

LookUp(Assets, Title = DataCardValue9) &

LookUp(Assets, Title = DataCardValue9.Text)

(Where DataCardValue9 is the DataCard showing the station name that would match the title in assets)

 

Those didn't work and I'm guessing it's because I don't have that formatted correctly.

Ok, how many assets do you have I sharepoint to lookup? If it's over 500 that could be your issue, try using:

Search(Assets,datacard9.text,title) or

First(Filter(assets,title=datacard9.text),title)

There are 148 assets. I tried both of those formulas and they did not display any results. 

To be sure, that formula needs to be entered into the Item field of the Display Form correct? 

Sorry, I think I misread something earlier...Do they select the asset or does it look up from the user field?

 

If the asset form is looking up from the user form (asset form should be an edit form mode) and the item should be set to:

First(Filter(Assets, Title = datacard9.text))

 

 

The asset form should lookup from the user form. In all, I'd select the user from the user gallery, the userinfo form (display mode) would show the users' info and then the stationinfo form (in edit mode?) would display the station's info based on matching the title of the asset to the computer name field in the userinfo form (datacard9)

 

I added an Asset form in edit mode and tried the formula, but still didn't get any results. 

Ok the issue is the datacard part... should be datacardvalue9

 

Also, temporarily add a button and put the following: Newform(UserFormName); NewForm(AssetFormName)

 

 

Updated First(Filter(Assets, Title = DataCard9.text)) to First(Filter(Assets, Title = DataCardValue9.text)) and still nothing. 

For the heck of it, I also tried to make the User Form in Edit mode to see if that would work, but I'm still getting an "Invalid Argument Type" error.

 

By the way, thanks for your help with this, I appreciate it greatly.

take out the .text if it comes up with a mismatch then it could need text(datacardvalue9)

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,247)