cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Re: DropDown List resetting to default on Navigate

In my case, the entire form is resetting to default and I am not using the same data source in second screen.

 

The second screen taking a field value from first screen and filter another data source  and show the output in a gallery.

Highlighted
Frequent Visitor

Re: DropDown List resetting to default on Navigate

I have no values in the reset property nor a reset function and the second screen it is not using the same data source as the first.

It's only clearing out the value on the first screen the first time someone tries it in one session. If they enter 10 items in this session, items 2-10 work flawlessly without erasing the value. Once they exit the app and do it again it does the same behavior on the first instance.
Highlighted
Resolver II
Resolver II

Re: DropDown List resetting to default on Navigate

I also have the same problem, and it's exactly as s0ylaunica describes.

Highlighted
Power Apps
Power Apps

Re: DropDown List resetting to default on Navigate

@sankar_tr @SankarR @s0ylaunica @jzcase There is currently a known regression with forms resetting when navigating to screens that have not been loaded yet when Delayed load is enabled.  Disabling Delayed load in App settings -> Advanced settings often mitigates the issue.  A codefix is being worked on.

Highlighted
Helper I
Helper I

Re: DropDown List resetting to default on Navigate

What's the status of this issue?  I am having the exact problem where navigating from one screen to another that hasn't been loaded yet, resets my drop downs to their default values.  This is a problem because during the OnHidden event I'm saving the values of the dropdown.  Because the dropdown resets on navigation I keep saving the original default value rather than the one selected by the user.  This only happens if the screen being navigated to hasn't been viewed yet.  Once it's viewed, the patch works as it should during navigation.

 

Setting Delayed Load off fixes it but I'm wondering if the codefix that solves this issue has been released.

 

Thanks,

Dan

Highlighted
Frequent Visitor

Re: DropDown List resetting to default on Navigate

I'm having this exact issue now, so I'd say the codefix hasn't been deployed or hasn't worked.  However, I disabled Delayed Load and it appears to have fixed the fault for me.

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (8,840)