cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WebPortal
Post Prodigy
Post Prodigy

Dropdown is empty

This is the formula for my dropdown:

 

Filter(MySPList, ColumnA = "XPTO").Name

 

Which returns a table with names.

 

However, the dropdown is empty:

WebPortal_0-1610131593959.png

 

Why?

 

1 ACCEPTED SOLUTION

Accepted Solutions
RandyHayes
Super User III
Super User III

@WebPortal 

DropDowns sometime get confused.  Try deleting the formula completely (select all and cut) and then put it back (paste).

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

View solution in original post

5 REPLIES 5
eka24
Super User III
Super User III

Try this:

Filter(MySPList, ColumnA = "XPTO")

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 

Drrickryp
Super User II
Super User II

@WebPortal 

Check the value dropdown in the right side of the screen and make sure it is showing the right field in your filtered table. You can probably drop the " .Name" from your formula.

RandyHayes
Super User III
Super User III

@WebPortal 

DropDowns sometime get confused.  Try deleting the formula completely (select all and cut) and then put it back (paste).

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

View solution in original post

WebPortal
Post Prodigy
Post Prodigy

Hi,

 

I've just closed and opened the app again, and now it works...

 

🙂

 

Thanks a lot for helping!

RandyHayes
Super User III
Super User III

@WebPortal 

Yep...that too!  Like I say, sometimes dropdowns and comboboxes (and charts too) have this moment of not doing what is obvious.  Delete and paste back usually works.  Sometimes I have to set them to another data source (usually the DropdownSample) and then back.  And then sometimes it's a get out and back in!

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (2,504)