cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AlanBo
Frequent Visitor

Dropdown menu doesn't show input in mobile version

Hi, 

 

When i create a dropdown menu which allows input, i'm unable to see what i type in the mobile version, also, no results is shown when connected to a datasource.

 

It works fine in the desktop version.

8 REPLIES 8
v-xida-msft
Community Support
Community Support

Hi @AlanBo,

 

Could you please share a bit more about the issue within your app?

Could you please share a bit more about the Dropdown menu that you mentioned? Is it a Combo box control?

Further, could you please show more details about the data source that you mentioned? Is it a SP list data source?

 

The user @calvares and @AlanBo has faced similar issue with you, please check the following threads:

https://powerusers.microsoft.com/t5/Connecting-to-Data/Person-drop-down-not-displaying-names/m-p/152...

 

https://powerusers.microsoft.com/t5/General-Discussion/Searchable-Dropdown-in-datacard-doesn-t-work-...

 

I suppose that the data source that you mentioned is a SP list, and the Dropdown menu (Combo box control) field is connected to a Person or a Choice type column within your SP list, is it true?

 

I have made a test on my side, and don't have the issue that you mentioned. Please check if the version of PowerApps Mobile App within your Mobile device is the latest version, if not, please upgrade it to the latest version, then check if the issue is solved.

 

If the issue still exists, please take a try to uninstall the PowerApps Mobile App from your Mobile Device, and then re-install it again to check if the issue still exists.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi, 

 

I've just created a new SP list, containing a "people" column.

Afterwards i created an app from the SP.

The app works when i run it on my desktop.

But when i run it on my mobile no results are shown when i search for people.

 

please see the attachments

Hi @AlanBo,

 

I have made a test on my side, and don't have the issue that you mentioned.

 

Please take a try with above solution I provided to check the issue within your app.

 

If the issue still exists, please take a try to enable the "People and Groups" option rather than "People only" option for the Person type column in your SP list:13.JPG

 

 

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi, 

 

It works with the new app.

But my old app still doens't work. I've tried to delete the column and create it again after your instructions, but it still doesn't work.

 

should i redo the entire from, or create a new SP list to get this to work?

Hi @AlanBo,

 

After you delete the Person column and re-create it again within your SP list, please take a try to re-create a new connection to your SP list data source within your app, then check if the issue is solved.

 

If the issue still exists, you may need to re-create your SP list to fix your problem.

 

If you have solved your problem, please go ahead and click “Accept as Solution” so that this thread will be marked for other users to easily identify.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi, 

 

It now works in both applications.

But i found the error. I don't know if this is because of my phone.

If i add the dropdown menu in the top of the app, it works. but if i add it in the button, it doesn't...

 

Please see the attached test (sorry about the background noice...).

Hi @AlanBo,

 

Based on the vedio that you provided, I found that when you type text within the second Person field, the focus of inputs is not on the Combo box control.

 

Please make sure the focus of the inputs is on the second Combo box control when you type text within the Combo box control.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi,

 

i'm sure that i focus the box.

I click it serveral times, but it doesn't work

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,938)