cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Dropdown no longer automatically showing first item

I have a form with a text input box, and dropdown.  The dropdown Items formula is

      Office365Users.SearchUser({searchTerm:TextInput1.Text}).DisplayName

The Default value for the dropdown has always been "".

 

Until this morning, as I typed values in the Text Input box the first item returned by the Items formula above would appear in the Dropdown list of items AND in the box area.  By some strange occurance this morning, only the Dropdown list of items shows data. The box area is blank until I select a value from the items.

 

I don't know what could have changed this morning. 

 

Dropdown question.png

 

Dropdown question2.png

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Continued Contributor
Continued Contributor

https://powerusers.microsoft.com/t5/General-Discussion/Issue-with-new-Powerapps-version-3-19014-8-Dr...

 

More information and a resolve here.

 

Basically a bigfix stopped the default first item selection. This will be rolled back today but there is a fix in the thread

 

"It looks like some people relied on this behavior to have the first item selected by default. In order to get that behavior, people will need to set the value of the Default property to the first item in their dataset (i.e. First(DATA_FROM_ITEMS).FIELD_FROM_VALUE) )."

View solution in original post

3 REPLIES 3
Super User II
Super User II

Hi @DunstonJ

 

I am not sure what changed, but I am getting the same results as you at the moment.

 

It might make sense that a drop down behaves this way as in the past you had to do a few things to make sure that the drop down doesn't automatically select the first value. Maybe Microsoft 'fixed' it.

 

Consder using a Combobox for this function, they work great.

 

Have a great day.

 

twitter: @dawidvh

youTube: https://www.youtube.com/channel/UCIMe_ErQZP5chbI9UyW0xLw

>>If you found this reply helpful, please mark this as the answer to close the topic and make it easier to find for other people with similar questions.<<

Having the same issues. Maybe the did some type of update? 

Continued Contributor
Continued Contributor

https://powerusers.microsoft.com/t5/General-Discussion/Issue-with-new-Powerapps-version-3-19014-8-Dr...

 

More information and a resolve here.

 

Basically a bigfix stopped the default first item selection. This will be rolled back today but there is a fix in the thread

 

"It looks like some people relied on this behavior to have the first item selected by default. In order to get that behavior, people will need to set the value of the Default property to the first item in their dataset (i.e. First(DATA_FROM_ITEMS).FIELD_FROM_VALUE) )."

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (9,430)