cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

EDIT FORM // NEW FORM ERRORS ===> PLEASE HELP!

HELLO POWERAPPS COMMUNITY:

 

I HAVE AN APPLICATION WITH 3 PAGES: MAIN, DETAILS, EDIT/NEW

 

PROBLEM 1:

 

WHEN I CLICK ON AN EXISTING RECORD, IT TAKES ME TO THE DETAILS SCREEN FOR THAT RECORD. THEN WHEN I CLICK THE EDIT BUTTON ON THE TOP RIGHT CORNER IT TAKES ME TO THE EDIT SCREEN. MY PROBLEM IS: EACH RECORD HAS MULTIPLE DROPDOWNS, WHERE EACH DROP DOWN COMES FROM A SEPERATE TABLE FROM EXCEL SPREADSHEET. SO WHEN THE EDIT SCREEN COMES UP, IT SHOWS ENTRIES ON THE DROPDOWNS THAT ARE NOT SELECTED FOR THIS RECORD. IT JUST HAS RANDOM VALUES FROM THE DROPDOWNS SELECTED. HOW CAN I HAVE THOSE VALUES SELECTED INITIALLY WHEN THE EDIT SCREEN COMES UP.

 

PROBLEM 2:

 

SIMILAR TO 1ST QUESTION, WHEN I WANT TO ADD A NEW ENTRY, THE SAME PRE SELECTED DROP DOWNS ARE SELECTED. HOW CAN I MAKE IT WHERE WHEN A NEW RECORD IS ADDED, THE DROPDOWNS ARE PRE SELECTED/FILLED WITH THE 1ST ENTRY IN THE TABLE FROM EXCEL SPREADSHEET (WHICH IS: '-').

 

 

PLEASE IF ANYONE CAN HELP ME FIX THESE ISSUES ASAP I'D REALLY APPRECIAITE IT!

 

THANKS

3 REPLIES 3
Community Support
Community Support

Hi @Anonymous,

 

Could you please share a bit more about your app's configuration?

Could you please share more details about your data source within your app?

 

For your first question, please check if the OnSelect property of the Edit Button (Click it to go to Edit Screen) control within your Detail Screen is set to following formula:

EditForm(EditForm1);Navigate(EditScreen1, ScreenTransition.None)

In addition, please also check if the Item property of the Edit Form within your Edit Screen set to following formula:

BrowseGallery1.Selected

For your second question, please check if the OnSelect property of the Add (Click it to add a new record) Button within your MAIN screen is set to following formula:

NewForm(EditForm1);Navigate(EditScreen1, ScreenTransition.None)

I have made a test on my side, if the "-" is the first entry in my Excel table, it would also be acted as pre-selected value within my Drop down control automatically.

 

In addition, you could also take a try to set the Default property of the Drop down control to following formula to achieve your needs:

First(Table1).Category

Note: The Table1 represents the Excel data source within my app. The Category is a column in my Excel table, which is used as the display value within the Dropdown control.

 

More details about the Data Forms (Edit Form and Display Form) in PowerApps, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/working-with-forms

 

More details about the Dropdown control in PowerApps, please check the following article:

Drop down control in PowerApps

 

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hello,

 

Thank you for the help. My problem to question #2 was resolved. Unfortunately, the formula's you gave me for problem #1, I had already had those same formulas logged in but unfortunately its still the same problem. When I click the edit button and it directs me to the edit screen, the drop downs are now just pre-filled to "-" (which is the first entry in the tables the drop downs are getting their source from).This is okay when making a complete new entry, but i can not have this when editing an already extisting entry.

 

There are a total of 8 drop downs. Each drop downs Item property is simply the name of the table which was imported from excel.

 

Please if anyone can help me resolve this issue ASAP that would be greatly appreciated.

 

 

Thanks

 

moiz

Anonymous
Not applicable

Hello:

 

Ok so I got my question to work partially. For all the dropdowns default property I put the following: If(EditForm1.Mode = FormMode.New,First(DataClass).'C1 Data Classification',EditForm1.Mode = FormMode.Edit,Parent.Default)\

 

For new entries, this works like a charm (all the fields are blank). But for exisitng records which I need to edit, it works partially. Some of the records/entries edit screen dropdowns are pre-filled to the previous selections (GOOD). But, some records/entries edit screen dropdowns are pre-filled to blank ("-"). Not all the dropdowns of that record, but sometimes 1, 2, or 3 of them (usually the same ones). i beleive it is all random. I dont know why this is. Dont know what i am doing wrong or what is causing this issue.

 

Please, if anyone can help resolve this issue ASAP I would greatly appreciate it.

 

Thanks,

 

moiz

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (33,181)