cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
raristondo
Regular Visitor

ERROR FROM TOKEN EXCHANGE. BAD AUTHORIZATION TOKEN. THE ACCESS TOKEN HAS EXPIRED

I have this error when using my apps, it happens many times in the day, and we have not made changes to the app, the last thing that was done was to update Power Apps on the tablets. Someone has the same problem or an idea how to solve it.

 

"ERROR FROM TOKEN EXCHANGE. BAD AUTHORIZATION TOKEN. THE ACCESS TOKEN HAS EXPIRED"

40 REPLIES 40
Jinman
Microsoft
Microsoft

Checked telemetry. You are right. The error,http400, got increased recently. I dropped an email to folks to look at this matter with priority. will keep you posted.

Thank you @Jinman 

_____________________________________________________________________________________
Like my answer? - Hit that Thumbs Up. Resolved the Issue? - Hit Accept as Solution.
This helps others find solutions to future issues!

Hi Rob, without having a lot of details about your app or flows, it is possible that your issue is being caused by policies in your tenant:

Things to check (a tenant administrator will need to make this changes).

 

  1. If the connections you are using require MFA, make sure that your tenant is configure to allow users to remember MFA on devices they trust (checkbox at the bottom):

https://docs.microsoft.com/en-us/azure/active-directory/authentication/howto-mfa-mfasettings#mfa-ser...

 

  1. Make sure that your tenant token policies are not configured for short life spans:

https://docs.microsoft.com/en-us/azure/active-directory/authentication/howto-mfa-mfasettings#mfa-ser...

If you don't have admin access, I may be able to provide alternative work arounds. If you could share your App id (the app URL when playing the app would suffice) I may be able to figure out a mitigation.

 

Thanks,

Alan

Here's the app I was testing it on.

 

https://web.powerapps.com/webplayer/app?tenantId=4f3526f9-97d6-412d-933a-4e30a73110f4&source=portal&...

_____________________________________________________________________________________
Like my answer? - Hit that Thumbs Up. Resolved the Issue? - Hit Accept as Solution.
This helps others find solutions to future issues!

It's occuring on all apps that access Sharepoint though right now.

 

_____________________________________________________________________________________
Like my answer? - Hit that Thumbs Up. Resolved the Issue? - Hit Accept as Solution.
This helps others find solutions to future issues!

@AlanCit only started happening in the past week, and we have had apps up and running since around february. Assuming with a few different people all in this thread experiencing the same issue suddenly something might have happened, potentially with the most recent iOs update since it does not occur on the iPad running an older version of iOs

 



The most recent stable release, iOS 12.4, was released on July 22, 2019.

 


Which is around same time we all began having issues

_____________________________________________________________________________________
Like my answer? - Hit that Thumbs Up. Resolved the Issue? - Hit Accept as Solution.
This helps others find solutions to future issues!

Shared a few comments ago the exact code on the app i made to test it if you wanna look at it
_____________________________________________________________________________________
Like my answer? - Hit that Thumbs Up. Resolved the Issue? - Hit Accept as Solution.
This helps others find solutions to future issues!

I use Android and I have the same problem for two weeks, in my opinion the update of Power Apps caused this inconvenience, since it coincides with the beginning of the problem. On July 29 they released another update that I only installed on 3 tablets and I am still waiting for the problem to improve. Greetings.

Hey raris! I do think its at least partially OS related as the iPads I have running an outdated iOs build all function properly. Unless those older iPads are stuck on an outdated powerapps build because they cant update past a certain point because of outdated iOs. Will check that Monday when back in office though.
_____________________________________________________________________________________
Like my answer? - Hit that Thumbs Up. Resolved the Issue? - Hit Accept as Solution.
This helps others find solutions to future issues!

Hi Rob, we are still investigating the root cause. One more thing, would you mind sharing the date time settings and the location settings of the two devices? (screenshots should be fine) I'm trying to compare whether they have different settings, for example time zone and automatically setting time zone based on location.

 

Thanks,

Alan

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,146)