cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ConRobMcC
Frequent Visitor

EditForm new values not being reflected in the data source

Hi all,

 

I've been working on creating a PowerApp connected through a SQL Server database. The only thing causing me grief at the moment is the Edit/Submit Form. For some reason whenever I try and update a record in the edit form, and click my button that submits the form, the new data values aren't being pushed to the datasource. The new values stay reflected on the form itself, but the datasource isn't getting the new values. I have messages checking both the OnSuccess and OnFailure actions, but the OnFailure never triggers so I can't be certain what's going wrong here.

 

Does anyone have any ideas as to what could be the problem? I've tried searching the forums and google, but couldn't come up with anything that helped me fix the issue.

20 REPLIES 20

Is this supposed to work for Item? I'm getting an error that the function is not supported.

Helpful resources

Announcements
Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Super User 2 - 2022 Congratulations

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (4,446)