cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lephas
Helper I
Helper I

EditView gets Redirected to NewForm (Bug?)

I am struggling with a Powerapps Form with a Sharepoint List behind it. 

I have a Sharepoint List with 2 Fields that seem to cause this behaviour: (reloading when i Edit a List Item)

1)Attachment

2)Dropdown List with Radio Buttons

I have a separate Gallery that uses the Attachment Field as a source:

 

 

#Items:
Attachment_Field.Attachments

 

 

And i have a Field with the Dropdown Options. Since PowerApps doesnt recognize the Radio Buttons I had to remove the Dropdown Field and replaced it with the Radio Button Input:

 

 

#Items:
Choices([@'Sharepoint List'].'Dropdown_Field')
#Default:
ThisItem.'Dropdown_Field'.Value

 

 

Here comes the really weird part. When I remove the Gallery - my form works fine. 

When I remove the Radio Button Field or Replace it with the Dropdown Field Input it works fine.

How do I troubleshoot this? Does anyone know a workaround? 
This is driving me crazy so any help is highly appreciated!

1 REPLY 1
KajalGupta15
Helper I
Helper I

Refresh your data source or create new tables and try to add controls again

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Community Call Conversations

Introducing the Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (4,499)