cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Editing a SharePoint List form in PowerApps - no longer Saves updated information

I have a list and modified the standard form in SharePoint to accomodate more information.  But when i open an exisiting list item and edit it, I cannot save when new information is updated in it.  See attached picture:SharePointFormEditNotWorking.PNG

 

9 REPLIES 9
Resolver I
Resolver I

@Anonymous, did you the customize option in from SharePoint list using the link below?

https://powerapps.microsoft.com/en-us/blog/separate-custom-forms/ 

 

Was the save button available before or is this the first time you have issues with? If it was working before can you revert the app to the previous version and then check what change caused the issue.

 

 

 

 

Anonymous
Not applicable

It stopped working when I clicked the "customize" in PowerApps button.   Prior to that it was working fine.

sharepointformsave.gif

can you try setting the form settings to use default SharePoint form?

Form-Settings.PNG

Anonymous
Not applicable

If I do that, will I lose my progress???

NO. it will not, you will still have PowerApps customized form. When you choose the default form then it will render the form using standard OOB and ignores the Powerapps customized form.

I suggested this because you didn't make any changes except clicking on Customize button.

Anonymous
Not applicable

Yes, resetting it back seems to work fine.

sharepointformsave2.gif

 

 

 

Community Support
Community Support

Hi @Anonymous,

 

Please customize this form, and then check the formula in OnSave property of the SharePointIntergration. See if the SubmitForm function has the right Form name inside:

Capture.PNG

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

I found the problem.

 

So, since I am using one data source, I had 3 different forms connectors to that one data source/SP list.   So, the submitform button would only register one connection to the list.   

 

I am going to have to rebuild this from scratch again and try to expand the form all the way out to accept only one data source.

 

More added complexities...but still doable.... I hope.

Anonymous
Not applicable

So, I rebuild the form.  From this GIF, you can see that in the original, I can save without any problems.

sharepointformsave4.gif

 

BUT when I modify the form, and the only things I do is make the screen to "Landscape" and move the fields around I now get an error message.   You can see in the following error message:

 

sharepointformsave3.gif

 

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (27,384)