cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Email not sending when clicking a button. Failing on mobile devices. Works on computers.

Hi, 

 

Hoping someone can help. I have created an app and I am trying to send an email to an Outlook 365 account.

It works when I do it from a computer but when I am trying to do the same from and Android Device and an Apple Device, I get an error message saying the following, see attached screen shot.

 

This is the code I am using see below. I have blanked out the three email addresses. But as I mentioned I can’t seem to work out why it sends from a computer and not a mobile device.

I have even added a gmail account to see if that narrows down the issue, to see if it is just Office365 its having a problem with. But doesn’t seem to be. So, two are Office365 email addresses and the other is gmail.

Oh, I forgot to mention I have also included the correct connectors on the app as well. 

Apologies for all the text, I just wanted to include so that you guys can see everything.

 

Office365.SendEmail ("xxxxx@xxxxxx.co.uk , xxxx@xxxxxxx.co.uk , xxxxxxxxx@gmail.com" , "Declaration Signature" ,"By signing, I declare that all the information supplied on the previous form (xxxxxxxx xxxxx Questionnaire) is true and complete to the best of my knowledge and belief. I also understand that it is my responsibility to report any changes to my circumstances as soon as is practicable. <br/> I further confirm that I have been inducted by xxxxxxxxxxxxx, that I have read, understood and will carry out all of my working practices according to the xxxxxxxxxxxx Risk Assessments, Method Statements & Safe Systems of Work. I understand that failure to disclose any information or to knowingly provide false information may have a detremental effect on my contract to work with xxxxxxxxxxxxx.<br/>" & "<br/>" & TextInput3 & "<br/>" & DatePicker1, {Attachments:Table ({Name: "Inductee Signature.jpg", ContentBytes: PenInput2.Image,  '@odata.type' : ""}),IsHtml: true});UpdateContext({BlankImage: PenInput2.Image}); Navigate (Successful_1, ScreenTransition.Fade)

 

Thanks for your help in advance.

12 REPLIES 12
Anonymous
Not applicable

Hi @WarrenBelz 

My apologies. I did add the screenshot to the post, titled: ScreenShot. I may not have made it clear enough.

The screenshot was taken from my tablet during the use of the application. 

From reading that article I think i may know what the issue is. Thanks for all your efforts.  

Thansk @Anonymous ,

Looking back, I saw a number of things to fix in the code and started on them. I did not notice the attachment for that reason.

If this thread has fixed the coded issues, please consider Accept as Solution as it will make it easier to find and also close the item.

Anonymous
Not applicable

Hi, @Max44 

Looks like it was a bit of both. I was also getting some help from another user, but I used your advice and theirs. 

Thanks. 

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Community Call Conversations

Introducing the Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (5,012)