cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper IV
Helper IV

Embed PowerApp in SharePoint Page not working in Internet Explorer

I am trying to embed powerapp on SharePoint Modern Page using iframe or using Pageviewer webpart in Webpart page.

 

It works fine in google chrome browser but doesnot works in Internet Explorer .

 

When embedded on modern pages it shows below error. It asks for sign but nothing after that. Screenshot below.

Embedd PowerApp Issue1.png

 

When i use page viewer to view the app on SharePoint Webpart Page. It just keeps on loading. Screenshot below.

 

Embedd PowerApp Issue2.png 

 

6 REPLIES 6
Highlighted
Community Support
Community Support

Re: Embed PowerApp in SharePoint Page not working in Internet Explorer

Hi @manjotsingh057,

 

I just embed a PowerApps app on my SharePoint page following https://powerapps.microsoft.com/en-us/blog/embed-powerapps-on-sharepoint-pages/, and it works correctly on IE. I'm using IE11.

Capture.PNG

 

The iframe code I am using above is like following.

<iframe width="1024px" height="768px" src="https://web.powerapps.com/webplayer/iframeapp?hideNavBar=true&source=iframe&screenColor=rgba(104,101,171,1)&appId=/providers/Microsoft.PowerApps/apps/[AppID]" />

Make sure that you have read through the documentation and see if there is anything you did wrong.

 

Also, try to clear cache in IE and try again. 

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper IV
Helper IV

Re: Embed PowerApp in SharePoint Page not working in Internet Explorer

Hi Mona,

 

I have verified as per mentioned link, followed same steps. I tried clearing cache also but still not working.

 

I checked the browser console. Got following error. May be related to  forbidframing ?

Embedd PowerApp Issue3.png

Highlighted
Helper IV
Helper IV

Re: Embed PowerApp in SharePoint Page not working in Internet Explorer

Also it has a SQL connection to display records from SQL table.

Highlighted
Helper IV
Helper IV

Re: Embed PowerApp in SharePoint Page not working in Internet Explorer

hi @v-monli-msft,

 

Anything else that i can try on this ?

 

Thanks

Manjot Singh

Highlighted
Advocate II
Advocate II

Re: Embed PowerApp in SharePoint Page not working in Internet Explorer

This article states that 'To access PowerApps using Internet Explorer 11, you must turn off Compatibility View.'

 

The ETA for a PowerApps webpart is likely to be Q1 2018 if that helps?

 

Best of luck

Highlighted
Helper IV
Helper IV

Re: Embed PowerApp in SharePoint Page not working in Internet Explorer

Thanks @geraint will wait for the PowerApps Webpart release.

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (4,324)