cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Embedded Power Apps app in SharePoint Page displays black cover

Hi Pros,

 

I created a simple app to get and send data to SharePoint lists. It looks fine if I browse outside SharePoint (on PowerApps mobile app, on PowerApps desktop app, on browser directly through web link, etc.). But, if I embed the app (any app) in a SharePoint Page, a black cover is beign showed. All controls are enabled and I can input text and click on buttons; but I can't see them.

 

It seems like a screen resolution related issue. I just tested using a 1366 x 768 resolution and this black section appears and seems to be growing as scroll down (like a parallax effect). After that, I tested using a 1920 x 1080 resolution and, as screen don't need scroll-bar and there is no way to scroll down, black cover doesn't appear.

 

1366 x 768 resolution:

Anotación 2020-06-03 172401.png

 

1920 x 1080 resolution:

 

Anotación 2020-06-03 172717.png

 

It would be great if anyone has resolution.

 

Thanks.

21 REPLIES 21
Highlighted
Community Support
Community Support

Hi @BrianGarnica ,

Do you mean that this issue would be shown up when the Scroll bar is existed?

 

Based on the issue that you mentioned, I have made a test, and the issue is confirmed on my side. If I embed a canvas app through the "PowerApps web part", the issue would show up. I think this issue may be related to layout.

As an fixed solution, I agree with your thought almost. You could consider change your canvas app resolution to 1920 x 1080 to fix this issue.

 

Currently, I could not come up with other better solution to fix this solution. I would post this issue to my Product Team, if this issue is fixed. I would reply here. As an temporary solution, please try to change your canvas app resolution to 1920 x 1080 to fix this issue.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Regular Visitor

I have the same issue in Edge and Chrome however when I view the page in Firefox, it shows up ok. Not sure why. Glad I found this post. I will try changing resolution.

Highlighted

Changing the resolution doesn't seem to help.

 

Anyone have any other suggestions?

Highlighted
Frequent Visitor

Just chiming that this also first started happening on my company's SharePoint on 6/3/2020. My current solution has been to shrink the size of the embedding so the app fits without having to scroll down the page, but this makes any small text or buttons harder to read/use.

Highlighted

Thanks for the suggestion. Yes, this just started happening for us too. Must have been a change introduced by an upgrade or something.

Highlighted

Also to add, it only happens in Chrome and Edge. Firefox shows the embedded PowerApp perfectly.

Highlighted
Frequent Visitor

Just happened to us as well. Any solution?

Highlighted
Frequent Visitor

Yes Please, this problem seems to have started recently, and I never had this issue before June.  Can we get this issue up the chain to Microsoft and PowerApps somehow?

Highlighted
Frequent Visitor

 I have a ticket opened with Microsoft and was on the phone with them yesterday. They were able to reproduce the issue and are working on it. More to come ...

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (2,216)