cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BrianGarnica
Frequent Visitor

Embedded Power Apps app in SharePoint Page displays black cover

Hi Pros,

 

I created a simple app to get and send data to SharePoint lists. It looks fine if I browse outside SharePoint (on PowerApps mobile app, on PowerApps desktop app, on browser directly through web link, etc.). But, if I embed the app (any app) in a SharePoint Page, a black cover is beign showed. All controls are enabled and I can input text and click on buttons; but I can't see them.

 

It seems like a screen resolution related issue. I just tested using a 1366 x 768 resolution and this black section appears and seems to be growing as scroll down (like a parallax effect). After that, I tested using a 1920 x 1080 resolution and, as screen don't need scroll-bar and there is no way to scroll down, black cover doesn't appear.

 

1366 x 768 resolution:

Anotación 2020-06-03 172401.png

 

1920 x 1080 resolution:

 

Anotación 2020-06-03 172717.png

 

It would be great if anyone has resolution.

 

Thanks.

21 REPLIES 21
richdiMSFT
Power Apps
Power Apps

Hello All,

 

There seems to be a bug introduced between embedded canvas apps and chromium build 83 when you scroll. We are trying to find the root cause and a fix. Right now we don't have a workaround other than using a non-chromium browser. We actively investigating this issue. 

 

Sorry for the pain,

Rich Dickinson

PM Power Apps

Anonymous
Not applicable

Thank you@richdiMSFT for looking into this. Our company uses primarily Chromium-baed browsers (Edge and Chrome), and this bug is delaying an important rollout.

 

I used Google Chrome Canary which is on Chromium build 85, and the issue appears there as well.

Anonymous
Not applicable

I am also experiencing this issue

Anonymous
Not applicable

@richdiMSFT Any update on the fix for this bug? It's currently a showstopper for us.

kbliff
Frequent Visitor

Microsoft applied a fix last night, which seems to be somewhat working on some pages but unfortunately not consistently 😞 I just reached out to Microsoft to let them know.

Anonymous
Not applicable

Seems like the bug is gone in Chromium build 85. It is still showing in the current releases of Edge and Chrome which are still build 83.

Yes chromium fixed it in 85. We are rolling out a workaround for earlier builds this week. 

 

Rich

PM Power Apps

After testing, I confirm the fix works only with modern pages. All other page types are still having the issue.

Kbliff,

 

Can you provide some details where the workaround isn't working for you? The workaround trying to make the inner app domain and the embedded frame the same. This should be working for SharePoint web part and embedding on model forms. 

 

Thanks for any details you can provide,

 

Rich Dickinson

PM Power Apps

On publishing page - no more black bar as long as the embeded code contains the url: 

Helpful resources

Announcements
October Events

Mark Your Calendars

So many events that are happening this month - don't miss out!

Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Users online (3,866)