cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PhilD
Kudo Kingpin
Kudo Kingpin

Embedded app requests permission EVERY time page is refreshed

I understand PowerApps asking for permission to use a connector but I have one simple app that submits to a SharePoint list that I embedded in a SharePoint online page that prompts EVERY SINGLE time the page is refreshed (even for me and own both the list and the app). This really ruins the otherwise awesome experience I could deliver.

 

This seems unreasonable for sure and I don't think it is by design as I have other apps embedded the same way that only ask once per session, if that.

 

What could be causing this particular app to behave this way? 

 

  • SharePoint list permissions are 'contribute' for everyone in organization.
  • App permissions are 'can use' for everyone in organization.
  • One connection to this list in app.
  • Works fine once click allow, but a refresh 5 seconds later causes it to ask again.
  • Other apps in same environment do not behave this way.
  • Chrome, IE11 and FireFox (slightly less so in FireFox but still a problem).
1 ACCEPTED SOLUTION

Accepted Solutions

@PhilD, we've identified the issue but I'm not sure when we will have a fix for this. In the meantime, we do have a workaround for you. The next time you see the issue, click Switch Account and create a new sharepoint connection. This should resolve it for you.

View solution in original post

8 REPLIES 8
cherie
Power Apps
Power Apps

@PhilD, do you think you could collect a session id for me? (Alt + right click when embedded in sharepoint)

 

Can you give me a session id for the app that is requesting for permissions every time and one where it isn't requesting for permissions?

 

Thanks

Cherie

Sure thing, I appreciate your help. I will get this right now.

Not sure how to get the session ID when the app is embedded in a page. I opened the app in PowerApps, and got the session ID that way (it did prompt me when opening the app in PowerApps).

Session ID: 09dbd566-e921-46ed-ba66-c8b47d0bd2ea
PowerApps 3.18103.18

Here is one that works as expected

Session ID: 8dd0470d-5f69-4789-acac-dd77eb5d8756
PowerApps 3.18103.18

Thanks again for helping.

Alt + Right click will get you the session id when it's embedded.

 

I'll take a look at this

Great tip, thanks!

Here is the ID from an embedded session.

 

Session ID: 5f373c15-03ac-4dd4-95f0-865bcaddfa6e
PowerApps 3.18103.18

@PhilD, we've identified the issue but I'm not sure when we will have a fix for this. In the meantime, we do have a workaround for you. The next time you see the issue, click Switch Account and create a new sharepoint connection. This should resolve it for you.

View solution in original post

Great, thanks for your help with this.

 

That did seem to fix it for me. Would the expectation be that this will fix it for other users as well (hopefully)?

 

Again, I thank you for your help.

Yes that should fix it for the other users as well.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

Top Solution Authors
Top Kudoed Authors
Users online (8,503)