cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Employee Phone number missing

Hi,

 

In my powerapps I am using office365user as a datasource. I added below code to display user phone extension number but nothing showing whereas if I use .MobilePhone it does show use mobile no. What I am doing wrong? I have tried to use .BusinessPhones but still no luck. I can see user extension no through office365 mail.

 

Any help will be appreciable.

 

If(IsBlank(First(Employeeprofile).TelephoneNumber),"-",First(EmployeeProfile).TelephoneNumber)

 

Thanks

Mohammad

37 REPLIES 37

anything on this?  I see others have the same issue, so is it truly just an enhancement idea? or a bug?

@tcfranks- Can you please try setting this formula for a Label.Text and tell us what happens?

First(Office365Users.MyProfile().BusinessPhones.Value).Value

 

2017-06-07 11_13_35-PowerApps - Internet Explorer.png

 

It complains of invalid arguments

Thanks for trying @tcfranks,

  1. Was this a new app or an existing app?
  2. Can you please try to remove the Office365Users data source from the app and add it again?

The issue you are seeing is really weird, we are trying to understand what may be happening here.

it was created from the org brower template.

 

Deleting the data source and re-adding it seems to have fixed the issue.   Now I need to go figure out how to make it work for users other than myself.....

Great to hear that! For other users it should work as described earlier:

First(Office365Users.UserProfile("AnotherUser@contoso.com").BusinessPhones).Value

Hi,  Did you ever figure out how to make this work for other users?

 

Thanks,

Mike Bailey

Also,  I'm still unable to get this to work. I tried removing the data connection and adding it back but still get errors saying "The First function has some invalid arguments."

 

MIike 

@mbailey218To clarify, you removed the "Office365Users" connection from this menu and then added it again?

image.png

 

I had removed it from the whole app and not that screen. Just did and it worked.

 

Thanks,

Mike Bailey

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (20,177)