cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Racheli
Helper V
Helper V

Entity (table) prefix changing

Hey,

We are working on two environments 'Test' and 'Production'.

In both environments, there are the same tables with the same name and column name etc.

When we export the test app and import it to production we changed the connections and the flows and it always went good.

Suddenly, today when we export/import there were full of errors and some names even changed on their own.

Any clue why it happens?

Thanks

Racheli_0-1622552060417.png

Racheli_1-1622552070342.png

 

 

 

6 REPLIES 6
Jcook
Super User
Super User

Hello @Racheli 

 

What Tables are you using from Dataverse, are they standard ones or Custom Tables?

Is the Tables inside a Solution? The prefix (Publisher) should not be different between Environments

 


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Hey,

Custom Tables.

I don't think they are inside a Solution, they are in here:

Racheli_0-1622702865825.png

How does the prefix (Publisher) change between different Environments (as in the first picture)?

Does it matter if the tables are in the Solution or not?

Thanks

CNT
Super User
Super User

@Racheli The best way to ALM is to use Solutions.

  • Create a Solution in 'Test' and add all your Tables, Choices, Apps, Flows, Connections etc., into it.
  • Publish changes, Export (as a Managed Solution) and download the File
  • Import the File into 'Production'

 

Solution Exporter checks for dependencies. This way, you don't have to do anything in Production. Connections to Flows will be automatically established (This feature was added recently).

 

You can repeat this process when there are changes to be pushed from Test to Prod. This process can also be automated using Azure DevOps.

 

Hope this helps!

CNT
Super User
Super User

@Racheli Did you get the answer to your problem?

 

Please remember to give a 👍 and accept the solution as it will help others in the future.

Hey @CNT ,

I get the point and now it's clearer.

Although I would like to read about this more to make sure I'm doing it right.

One more thing please, recently, some things in the app has been changed by themselves.

In "App" -> "OnStart", there is a collection that the first and the last (marked in the picture) are kept changing, 

they should be: ItemId: ThisRecord.'Item number'

Racheli_0-1623045741888.png

Is there been an update in Powerapps lately?

Thanks in advance!!!

 

@Racheli Updates do come in regularly and sometimes they break things that are working. But I have never come across a situation where the code has changed by itself. Is there anyone else working in the same App? 

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (2,444)