cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Danny_L
Helper III
Helper III

Entry is required or has an invalid value.

Hello all,

I was having issues with my app so I decided to start a brand new app to see if there was something in my other app that was being funky. 

 

I have an Edit form that is tied to an SQL database table as the data source

 

Data connections in my app:

Office365Users

SQL Server - two servers with a combined 10 tables. Everything in my source database columns line up with what is "required" in the edit field

I have 3 combo boxes:

Failure Codes - Source is a table that has the failure code values in the Title column. All codes show when I hit the drop down

Point of Failure - Source is a diff table that has the point of failure values in the Title column. All codes show when I hit the drop down

Defect Generator - Tied to Office365 Users. This works as well. 

 

On submit I get the above message (The vagueness is beyond frustrating). Since this is a brand new app with brand new connections, I have no clue where to begin troubleshooting this. Any ideas???

Danny_L_0-1607552546007.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

I figured it out. I had the "Update" values incorrect for my first two drop-downs. I had to put ComboBox1.Selected.Title and repeat for the other combo box

View solution in original post

3 REPLIES 3
v-qiaqi-msft
Community Support
Community Support

Hi@Danny_L,

Do you mean that you  failed to submit the field as the screenshot shows?

I have found that there are multiple required fields needing filled in your form. The "*" operator represents the "required field" that means a mandatory field.

Please entry in the field with a "*" operator.

Besides, please try to set the required fields in PowerApps rather than in the data source.

Hope it could help.

Best Regards,

Qi

Danny_L
Helper III
Helper III

I have entered everything into the required fields that have a * and I still get the same error. See below. I obfuscated the info but you can see that there is data in each required field. The form does not submit.

 

Danny_L_0-1607626866757.png

 

I figured it out. I had the "Update" values incorrect for my first two drop-downs. I had to put ComboBox1.Selected.Title and repeat for the other combo box

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

Top Solution Authors
Top Kudoed Authors
Users online (96,618)