cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Aurora
Helper IV
Helper IV

Error Message: "The Specified record was not found. "

Hi all, 

 

I'm have an app that tracks when employees request to use their sick/vacation time. Another coworker and I can each use the app no problem, and it reads and writes as it needs to. The problem is, we have one user who always gets this error when he opens the app: 

 

 "The Specified record was not found. Server Response: Vacation_Holiday failed: Error from token exchange: The connection (europe-002/sharepointonline/432021f58ce3460e96c78695ba926c80) is not found. Please create new connection and change your application to use the new connection." 

 

I have tried editing our sharepoint list titled "Vacation_Holiday" and refreshing the connections in the app, but he still can't get the access he needs. In addition to seeing the error, two drop downs are blank for him, while for myself and others we see a list of employees. I'll include some images.

 

Does anyone have any idea what is going wrong? 

Aurora_0-1638982650953.pngAurora_1-1638982719733.png

I haven't selected the dropdown because it contains names of our employees, but it works for me.

4 REPLIES 4
Pstork1
Dual Super User III
Dual Super User III

What permissions does the user have to the list and the site where the list is housed?  The symptoms you are describing usually indicate that the user doesn't have the permissions they need.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Aurora
Helper IV
Helper IV

@Pstork1 

The user is listed as a "member" and his permissions are set to limited control (can edit). The other users besides myself are assigned the same level of permissions, and they can use the app. The user who can't use the app was able to use it without problems until a few days ago, and the app hadn't been edited in almost a year until today. 

 

Is there something I should specifically look for in that users permissions? 

Aurora
Helper IV
Helper IV

@Pstork1 

These are the user's permissions listed on SharePoint:

 

Aurora_0-1638984271941.png

 

Pstork1
Dual Super User III
Dual Super User III

If it used to work and the permissions haven't changed then you probably need to open a support ticket and have MS take a look.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,958)