cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ShaSha
Frequent Visitor

Error adding your data source: SharePoint List

I was trying to create a new app with a connection to a SharePoint list.  When I tried to create the connection to the list I recieved the following error:

 

ShaSha_0-1607462955165.png

 

I searched for possible solutions in the forum, and tried the solution here: 

https://powerusers.microsoft.com/t5/Building-Power-Apps/Cannot-read-property-name-of-undefined/td-p/...

, which was to add a column in my list called 'dataEntityDefinition', which then returned this similar, but slightly different error: 

 

ShaSha_1-1607463031150.png

 

I'm not really sure where to go from here, but any assistance would be appreciated.

Thank you!

6 REPLIES 6
flugaoveltem
Resolver III
Resolver III

Hi @ShaSha 

 

Is this happening with every sharepoint list ? 

Try to create a new sharepoint site and used it to host a new list. 

FrostedFlake
Resolver I
Resolver I

Try this Workaround:

  1. Export your SharePoint List to Excel
    FrostedFlake_0-1607502668642.png
  2. Open the downloaded .iqy Query (Excel will open)

  3. Import the opened Excel List to SharePoint again 
    https://support.microsoft.com/en-us/office/export-an-excel-table-to-sharepoint-974544f9-94bc-4aa8-91...

  4. In PowerApps try to add the DataSource again

 

 

Good Luck!

Hi @ flugaveltem - 

 

No, this error is not occurring with every SharePoint list.  I actually have another app that is connected to a different list, on the same SharePoint site, which is working fine.

Once the list is exported to Excel, and a connector made to the Excel workbook then the connection is established without errors.  However, I do need the connection to be for a SharePoint list, not an excel workbook, as in my experience some PowerApp functions and features that I would like to employ do not work well with an Excel connector.

What I mean is that you export the SharePoint list to Excel, so you can then re-import it as a new SharePoint list to see if the error still shows.

You are using Excel just for the purpose - after the re-importment you are working with the same connectors as usual.

 

Good Luck & let me know how it worked for you.

flugaoveltem
Resolver III
Resolver III

Hi @ShaSha 

Have you try open your app in open an Incognito window ? 

Remove the sharepoint coneection for your app. In app details, go to Connections

Captura de tela 2020-12-14 112750.png

Remove all sharepoint existing sharepoint connections, and try to recreate it. 

If you try to create a app from inside the list, it works ? 

flugaoveltem_0-1607966699117.png

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (3,353)