cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BrianS
Super User
Super User

Error in Helpdesk Example PowerApp

I am getting three errors in the app all related to this function:

If(RunFlow, HelpDeskFlow.Run("'" & TicketToRunFlow.ID & "'"));

The error is:

"Invocation of unknown or unsuorted function"

Any ideas why? I have gone thru the documentatin and checked that the flow exists

1 ACCEPTED SOLUTION

Accepted Solutions
v-xida-msft
Community Support
Community Support

Hi @BrianS ,

Could you please share more details about the error message within your app?

Have you added the corresponding flow connection within your app?

 

I have made a test on my side, and don't have the issue that you mentioned. Based on the issue that you mentioned, I think this issue maybe be related to flow connection within your app.

Please check if you have created corresponding flow connection within your app, or please check if the flow connection you created within your app is valid.

In addition, please also consider modify your formula as below:

If(
RunFlow,
HelpDeskFlow.Run(TicketToRunFlow.ID) /* <-- Do not wrap the value with single quotes ('') */
)

If the TicketToRunFlow.ID formula return a Number value, but the argument of the 'xxx'.Run() function is required to provide a Text value, please modify it as below:

If(
   RunFlow, 
   HelpDeskFlow.Run(Text(TicketToRunFlow.ID))     /* <-- Do not wrap the value with single quotes ('') */
)

 

Please consider re-create a new app, then re-add a new connection to your flow from your app, check if the issue is solved.

Recently, within PowerApps, there are some issues with connections created within PowerApps app or MS Flow, please check the following article for more details:

https://powerapps.microsoft.com/en-us/support/

The issue within your app may be related to this issue.

 

More details about starting a flow from an app, please check the following article:

Start a flow from an app

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
v-xida-msft
Community Support
Community Support

Hi @BrianS ,

Could you please share more details about the error message within your app?

Have you added the corresponding flow connection within your app?

 

I have made a test on my side, and don't have the issue that you mentioned. Based on the issue that you mentioned, I think this issue maybe be related to flow connection within your app.

Please check if you have created corresponding flow connection within your app, or please check if the flow connection you created within your app is valid.

In addition, please also consider modify your formula as below:

If(
RunFlow,
HelpDeskFlow.Run(TicketToRunFlow.ID) /* <-- Do not wrap the value with single quotes ('') */
)

If the TicketToRunFlow.ID formula return a Number value, but the argument of the 'xxx'.Run() function is required to provide a Text value, please modify it as below:

If(
   RunFlow, 
   HelpDeskFlow.Run(Text(TicketToRunFlow.ID))     /* <-- Do not wrap the value with single quotes ('') */
)

 

Please consider re-create a new app, then re-add a new connection to your flow from your app, check if the issue is solved.

Recently, within PowerApps, there are some issues with connections created within PowerApps app or MS Flow, please check the following article for more details:

https://powerapps.microsoft.com/en-us/support/

The issue within your app may be related to this issue.

 

More details about starting a flow from an app, please check the following article:

Start a flow from an app

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

I have attached a few screen grabs. The connection to the Flow looks correct, but I'm new to this. 

I tried your suggestions, but they are also giving errors. HelpDeskFlow is the name of the flow, and it is showing in the app.

 

I figured it out - totally user error!

I had not set up the flow correctly - I had the wrong Sharepoint list in the Site address.

 

Tahnks for your help!

Hi @BrianS ,

Have you solved your problem?

 

If you have solved your problem, please go ahead to click "Accept as Solution" to identify this thread has been solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hi @v-xida-msft @BrianS, After setting up my PowerApps and flow, other users are unable to receive email notifications, only the creator receives, any help for this issue 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,072)