cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate III
Advocate III

Error this morning - 3.19063.12, rolled back to 3.19062.20 and everything works again

Receiving this new error this moring when launching the application. It doesnt show up when in edit mode using the preview. Was working no problem this week and last night. Thoughts?

6 REPLIES 6
Highlighted
Dual Super User III
Dual Super User III

Are you loading/updating something when you start up the App?  Something using OnStart or OnVisible or something like that?  The error message is suggesting you are trying to create a new record with a value for the Email field that already exists.  Perhaps something in CDS?



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

The only write to a database which has been working for months is this:

 

// Add user into preferences/counter system if it doesnt exist
If(IsBlank(LookUp('PP-Application Preferences','User Email'=Lower(varCurrentLoggedInUser.Mail),crcbb_useremail)),
    Patch('PP-Application Preferences',Defaults('PP-Application Preferences'),{'User Email':Lower(varCurrentLoggedInUser.Mail)})
);
Highlighted

Now I'm getting this error. I'm thinking something is going on with CDS this morning.

Highlighted

Rolled back to version 3.19062.20 and everything is working again. Something broke in the latest version.

Highlighted

Hello,

the issue you've run into is typically due to an ETAG mismatch (where the server record has a change that's more recent that the patch originating from the client). However, I would have expected this to be an issue irrespective of the client version. We would like to investigate this further to root cause what happened.

Can you please help us with the appId for your app?

Also are there any Flows (or out of app operations) that update the same data?

 

Thanks,

Kunal.

Highlighted

@Kunal 

 

I think I have found the issue. In the Preview Features I disabled Explicit column selection in version 3.19063.12.

2019-06-28 13_19_41-Sales Support Portal [DEV] - PowerApps.png

This seems to have solved the errors I have attached. Previous to version 3.19063.12 this worked for over 3 months of delevopment and testing.

 

 

AppID: d1e59e1b-04bd-4ba1-bbd5-93ceeba45178

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (12,044)