cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
maverick17
Advocate IV
Advocate IV

Error this morning - 3.19063.12, rolled back to 3.19062.20 and everything works again

Receiving this new error this moring when launching the application. It doesnt show up when in edit mode using the preview. Was working no problem this week and last night. Thoughts?

6 REPLIES 6
Pstork1
Dual Super User
Dual Super User

Are you loading/updating something when you start up the App?  Something using OnStart or OnVisible or something like that?  The error message is suggesting you are trying to create a new record with a value for the Email field that already exists.  Perhaps something in CDS?



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

The only write to a database which has been working for months is this:

 

// Add user into preferences/counter system if it doesnt exist
If(IsBlank(LookUp('PP-Application Preferences','User Email'=Lower(varCurrentLoggedInUser.Mail),crcbb_useremail)),
    Patch('PP-Application Preferences',Defaults('PP-Application Preferences'),{'User Email':Lower(varCurrentLoggedInUser.Mail)})
);

Now I'm getting this error. I'm thinking something is going on with CDS this morning.

Rolled back to version 3.19062.20 and everything is working again. Something broke in the latest version.

Hello,

the issue you've run into is typically due to an ETAG mismatch (where the server record has a change that's more recent that the patch originating from the client). However, I would have expected this to be an issue irrespective of the client version. We would like to investigate this further to root cause what happened.

Can you please help us with the appId for your app?

Also are there any Flows (or out of app operations) that update the same data?

 

Thanks,

Kunal.

@Kunal 

 

I think I have found the issue. In the Preview Features I disabled Explicit column selection in version 3.19063.12.

2019-06-28 13_19_41-Sales Support Portal [DEV] - PowerApps.png

This seems to have solved the errors I have attached. Previous to version 3.19063.12 this worked for over 3 months of delevopment and testing.

 

 

AppID: d1e59e1b-04bd-4ba1-bbd5-93ceeba45178

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (3,476)