cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Error when importing API file

Hi, I am trying to create a custom connector in and I always get an error that the file that I am importing is not a JSON file however upon checking it is .json file.

 

Hoping someone can help me out. Thanks!

8 REPLIES 8
Highlighted
Super User
Super User

Re: Error when importing API file

That sounds like it's struggling to read the content properly due to structure issues - I would check for any typos or missing {} or ; or : using Visual Studio Code, as its easy to see where your opening and closing sections that way.


@iAm_ManCat

Please 'Mark as Solution' if someone's post answered your question and always 'Thumbs Up' the posts you like or that helped you!


Thanks!
You and everyone else in the community make it the awesome and welcoming place it is, keep your questions coming and make sure to 'like' anything that makes you 'Appy
Sancho Harker, MVP


Highlighted
Community Support
Community Support

Re: Error when importing API file

Hi @Anonymous ,

Could you please share a bit more about your scenario?

Do you want to create a custom connector based on a OpenAPI Definition file (JSON file)?

Further, could you please share a bit more about the schema of your OpenAPI Definition file?

 

Based on the issue that you mentioned, I think this issue may be related to the json schema defined within your OpenAPI Definition file.

The standard of OpenAPI Definition file should looks like below:

{
  "swagger": "2.0",
  "info": {
    "version": "1.0.0",
    "title": "SentimentDemo",
    "description": "Uses the Cognitive Services Text Analytics Sentiment API to determine whether text is positive or negative"
  },
  "host": "westus.api.cognitive.microsoft.com",
  "basePath": "/",
  "schemes": [
    "https"
  ],
  "consumes": [],
  "produces": [
    "application/json"
  ],
  "paths": {
    "/text/analytics/v2.0/sentiment": {
      "post": {
        "summary": "Returns a numeric score representing the sentiment detected",
        "description": "The API returns a numeric score between 0 and 1. Scores close to 1 indicate positive sentiment, while scores close to 0 indicate negative sentiment.",
        "operationId": "DetectSentiment",
        "parameters": [
          {
            "name": "body",
            "in": "body",
            "schema": {
              "type": "object",
              "properties": {
                "documents": {
                  "type": "array",
                  "items": {
                    "type": "object",
                    "properties": {
                      "language": {
                        "type": "string",
                        "description": "The 2 or 4 character language code for the text",
                        "x-ms-summary": "language",
                        "title": "Language",
                        "x-ms-visibility": "",
                        "default": "en"
                      },
                      "id": {
                        "type": "string",
                        "description": "An identifier for each document that you submit",
                        "x-ms-summary": "id",
                        "title": "ID",
                        "x-ms-visibility": "",
                        "default": "1"
                      },
                      "text": {
                        "type": "string",
                        "description": "The text to analyze for sentiment",
                        "x-ms-summary": "text",
                        "title": "Text",
                        "x-ms-visibility": ""
                      }
                    },
                    "required": [
                      "id",
                      "language",
                      "text"
                    ]
                  },
                  "description": "documents",
                  "x-ms-summary": "documents"
                }
              },
              "default": {
                "documents": [
                  {
                    "language": "en-us",
                    "id": "1",
                    "text": "I enjoyed the new movie after a long day."
                  }
                ]
              },
              "required": [
                "documents"
              ]
            },
            "required": true
          }
        ],
        "responses": {
          "200": {
            "description": "200",
            "schema": {
              "type": "object",
              "properties": {
                "documents": {
                  "type": "array",
                  "items": {
                    "type": "object",
                    "properties": {
                      "score": {
                        "type": "number",
                        "format": "float",
                        "description": "score",
                        "x-ms-summary": "score"
                      },
                      "id": {
                        "type": "string",
                        "description": "id",
                        "x-ms-summary": "id"
                      }
                    }
                  },
                  "description": "documents",
                  "x-ms-summary": "documents"
                },
                "errors": {
                  "type": "array",
                  "items": {
                    "type": "string"
                  },
                  "description": "errors",
                  "x-ms-summary": "errors"
                }
              }
            }
          }
        }
      }
    }
  },
  "definitions": {},
  "parameters": {},
  "responses": {},
  "securityDefinitions": {
    "api_key": {
      "type": "apiKey",
      "in": "header",
      "name": "Ocp-Apim-Subscription-Key"
    }
  },
  "security": [],
  "tags": []
}

Please check if the json schema defined within your OpenAPI definition file is proper.You could consider generate a OpenAPI definition file based on your REST API using the Apigee tool, then use the generated OpenAPI definition file to create custom connector in your PowerApps.

 

In addition, you could also consider take a try to create a custom connector from Blank based on your REST API. More details about creating custom connector in PowerApps, please check the following video resource or article:

https://www.youtube.com/watch?v=dBCS1nPsDiE

https://www.youtube.com/watch?v=cSzI093-xgk

 

https://docs.microsoft.com/en-us/connectors/custom-connectors/define-blank

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

Re: Error when importing API file

@v-xida-msft  and @iAm_ManCat 

 

I already created the custom connector however I am getting an error message:

 

Error: SPPhoto.PostPhoto failed: {"error":{"code":"AuthorizationFailed","message":"The authentication credentials are not valid."}}

 

Hoping for your kind assistance.

 

 

 

Highlighted
Community Support
Community Support

Re: Error when importing API file

Hi @Anonymous ,

Which authentication way do you use in your custom connector?

 

Based on the error message that you provided, I think there is something wrong with the connection you created to your custom connector in your app.

 

Please consider re-create a new connection to the custom connector in your app, check if the issue is solved.

 

Also please make sure that you have specified a proper Authentication way in your custom connector.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

Re: Error when importing API file

@v-xida-msft 

 

When I set it up, I did not set any authentication. I tried recreating the connector, but the issue persisted.

Highlighted
Community Support
Community Support

Re: Error when importing API file

Hi @Anonymous ,

Based on the error message that you mentioned, I think you need to provide a Authentication way in your custom connector to access your REST API server.

 

Please consider provide a Autentication (e.g. Basic Auth, API Key, OAuth 2.0) in your custom connector, then save your custom connector, check if the issue is fixed.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

Re: Error when importing API file

@v-xida-msft 

 

I added basic authentication but I am still getting the same error message

 

{
"swagger" : "2.0",
"info" : {
"description" : "Demov1",
"version" : "1.0.0",
"title" : "SPPhoto",
"termsOfService" : "https://prod-05.southeastasia.logic.azure.com/terms-of-service",
"contact" : {
"name" : "Test",
"url" : "-------------",
"email" : ""
},
"license" : {
"name" : "Apache 2.0",
"url" : "http://www.apache.org/licenses/LICENSE-2.0.html"
}
},
"host" : "prod-12.southeastasia.logic.azure.com:443",
"basePath" : "/workflows",
"schemes" : [ "https" ],
"paths" : {
"/---------------------/triggers/manual/paths/invoke" : {
"post" : {
"summary" : "Post photo to SP",
"operationId" : "PostPhoto",
"consumes" : [ "multipart/form-data" ],
"produces" : [ ],
"parameters" : [ {
"name" : "content-type",
"in" : "header",
"description" : "",
"required" : true,
"type" : "string"
}, {
"name" : "api-version",
"in" : "query",
"required" : true,
"type" : "string",
"default" : "2016-06-01",
"x-ms-visibility" : "internal"
}, {
"name" : "sp",
"in" : "query",
"description" : "/triggers/manual/run",
"required" : true,
"type" : "string",
"x-ms-visibility" : "internal"
}, {
"name" : "sv",
"in" : "query",
"description" : "1.0",
"required" : true,
"type" : "string",
"x-ms-visibility" : "internal"
}, {
"name" : "sig",
"in" : "query",
"required" : true,
"type" : "string",
"default" : "----------",
"x-ms-visibility" : "internal"
}, {
"name" : "filename",
"in" : "query",
"description" : "filename of uploaded file",
"required" : true,
"type" : "string"
}, {
"name" : "file",
"in" : "formData",
"description" : "file to upload",
"required" : true,
"type" : "file"
} ],
"responses" : {
"202" : {
"description" : "Accepted"
}
}
}
}
},
"definitions" : { }
}

 

 

By the way this is my api, I tried checking it with apigee and it doesn't contain any error.

Highlighted
Community Support
Community Support

Re: Error when importing API file

Hi @Anonymous ,

Do you want to create a custom connector to upload image file from PowerApps app your SP Library?

 

Please consider modify your OpenAPI definition file as below:

{
"swagger" : "2.0",
"info" : {
"description" : "Demov1",
"version" : "1.0.0",
"title" : "SPPhoto",
"termsOfService" : "https://prod-05.southeastasia.logic.azure.com/terms-of-service",
"contact" : {
"name" : "Test",
"url" : "-------------",
"email" : ""
},
"license" : {
"name" : "Apache 2.0",
"url" : "http://www.apache.org/licenses/LICENSE-2.0.html"
}
},
"host" : "prod-12.southeastasia.logic.azure.com",            /* <-- Please remove :443 port from the host url */
"basePath" : "/workflows",
"schemes" : [ "https" ],
"paths" : {
"/---------------------/triggers/manual/paths/invoke" : {
"post" : {
"summary" : "Post photo to SP",
"operationId" : "PostPhoto",
"consumes" : [],                  /* <--  Please remove the "multipart/form-data" from consumes preoperty. consumes property and produces should be set to empty */
"produces" : [],
"parameters" : [ {
"name" : "content-type",
"in" : "header",
"description" : "",
"required" : true,
"type" : "string"
}, {
"name" : "api-version",
"in" : "query",
"required" : true,
"type" : "string",
"default" : "2016-06-01",
"x-ms-visibility" : "internal"
}, {
"name" : "sp",
"in" : "query",
"description" : "/triggers/manual/run",
"required" : true,
"type" : "string",
"x-ms-visibility" : "internal"
}, {
"name" : "sv",
"in" : "query",
"description" : "1.0",
"required" : true,
"type" : "string",
"x-ms-visibility" : "internal"
}, {
"name" : "sig",
"in" : "query",
"required" : true,
"type" : "string",
"default" : "----------",
"x-ms-visibility" : "internal"
}, {
"name" : "filename",
"in" : "query",
"description" : "filename of uploaded file",
"required" : true,
"type" : "string"
}, {
"name" : "file",
"in" : "formData",
"description" : "file to upload",
"required" : true,
"type" : "file"
} ],
"responses" : {
"202" : {
"description" : "Accepted"
}
}
}
}
},
"definitions" : { }
}

Please modify your OpenAPI definition file as above.

Note: You do not need to specify a Authentication within your custom connector.

 

Please also reference to my OpenAPI definition file as below (Upload File from PowerApps to SP Library😞

{
  "swagger": "2.0",
  "info": {
    "description": "The API allows to upload image files added via Add Picture control to SP Library",
    "version": "1.0.0",
    "title": "PhotoToSPDemo",
    "termsOfService": "https://prod-11.southeastasia.logic.azure.com/terms-of-service",
    "contact": {
      "name": "API Team",
      "url": "https://github.com/ancherl",
      "email": "v-xida@microsoft.com"
    },
    "license": {
      "name": "Apache 2.0",
      "url": "http://www.apache.org/licenses/LICENSE-2.0.html"
    }
  },
  "host": "prod-11.southeastasia.logic.azure.com",
  "basePath": "/workflows",
  "schemes": [
    "https"
  ],
  "consumes": [],
  "produces": [],
  "paths": {
    "/63b63627f82c43e7ab3c035538506488/triggers/manual/paths/invoke": {
      "post": {
        "summary": "Upload photo to SP Library",
        "operationId": "UploadPhoto",
        "consumes": [],
        "produces": [],
        "responses": {
          "202": {
            "description": "Accepted"
          }
        },
        "parameters": [
          {
            "name": "api-version",
            "in": "query",
            "type": "string",
            "description": "",
            "required": true,
            "default": "2016-06-01",
            "x-ms-visibility": "internal"
          },
          {
            "name": "sp",
            "in": "query",
            "type": "string",
            "description": "",
            "required": true,
            "default": "/triggers/manual/run",
            "x-ms-visibility": "internal"
          },
          {
            "name": "sv",
            "in": "query",
            "type": "string",
            "description": "",
            "required": true,
            "default": "1.0",
            "x-ms-visibility": "internal"
          },
          {
            "name": "sig",
            "in": "query",
            "type": "string",
            "description": "",
            "required": true,
            "default": "nyYxv28DmDZX9MxpOcqv5ZjhLY2ecaaTYmH9koadruQ",
            "x-ms-visibility": "internal"
          },
          {
            "name": "fileName",
            "in": "query",
            "type": "string",
            "description": "fileName of uploaded image",
            "required": true
          },
          {
            "name": "fileContent",
            "in": "formData",
            "type": "file",
            "description": "file content of uploaded image",
            "required": true
          }
        ],
        "description": "Upload photo to SP Library"
      }
    }
  },
  "definitions": {},
  "parameters": {},
  "responses": {},
  "securityDefinitions": {},
  "security": [],
  "tags": []
}

Please also check and see if the following blog would help in your scenario:

https://repointtechnologies.com/saving-images-from-powerapps-to-sharepoint/

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (8,782)