cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
deeman
Frequent Visitor

Error when trying to retrieve data from network

Hi guys,

 

I am in need of your expertise as I am quite stumped on this. We have a PowerApp that for all intents and purposes was working quite happily around a month ago with no issues ( version 3.21085.24). The last 2 weeks, we have been experiencing a slow down of the app until last week Friday where it has completely now become unusable (current version 3.21094.25). 

 

In the past month I only added an extra sharepoint list to the PowerApp, and have begun optimising some bad code so you would think the experience should have improved with optmisations. I restored a version of the PowerApp to 8 weeks ago where I know for a fact we had no issues - however even on that version we are still experiencing a massive slow down on retrieving data.

 

I parse through all data from sharepoint to a collect first before displaying results, there are no instances of displaying data directly from a sharepoint library.

 

According to our network team, no ports were blocked recently in the firewall to prevent this from happening.

 

The error message I get from from the Monitor is " Error when trying to retrieve data from network".

 

Any guidelines would be greatly appreciated. Please let me know if you need more info or data or screengrabs

 

thank you!

 

1 ACCEPTED SOLUTION

Accepted Solutions
Sivarajan
Regular Visitor

Hi,

 

This might due to if you have a exceeded the Lookup field in SharePoint list. Please check.

 

Thanks.

View solution in original post

12 REPLIES 12
Sivarajan
Regular Visitor

Hi,

 

This might due to if you have a exceeded the Lookup field in SharePoint list. Please check.

 

Thanks.

deeman
Frequent Visitor

Hi

 

So managed to find the root cause - the size in one our Sharepoint Lists was Gigabytes in size instead of Megabytes - this caused the timeout.

 

Thanks for your reply. Found this solution earlier though but will mark it as accepted.

 

 

martinoau
Frequent Visitor

If someone has this problem trying Clear Cache or use other browser, sound stupid but works for me.

EDIT 14/2: If that don't work or is a temporal solution, try to Export the app and Import the app in the same place or in other user.

EDIT 29/03: Finally it was Sharepoint permissions

@deeman how do you change this setting?

Anonymous
Not applicable

@deeman  same issue one user is also getting

could you please on where you checked the size of list and how to fix it,

5by5T
Frequent Visitor

For anyone experiencing this issue with Dataverse, I resolved this issue by removing the connection to the table and re-adding it. I'm not sure why this happens, but that did seem to fix it.

Emmytau
Frequent Visitor

I'm having this problem, but none of the above can fix it

Did you ever find a solution? Also have this problem and none of the above fix it. Thanks!

annpui99
New Member

You can try to turn off "Formula-level error management" in app setting. The error message will be described in more details.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Solution Authors
Top Kudoed Authors
Users online (1,254)