cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate IV
Advocate IV

Errors function not recognizing SQL table as a datasource

If I type in the Errors function and look at the auto suggestions, I see my datasources.

I can click on a datasource and it auto-fills it into the Errors(...) function, but the function says it's an invalid name.

Any suggestions? Datasource is an azure hosted sql table, if that matters. Thanks

 

InvalidNameInErrors.png

1 ACCEPTED SOLUTION

Accepted Solutions

It could be an issue with the way intellisense is substituting your selection. PowerApps folks have to look into that substitution issue. Can you try surrounding the datasource name with single quotes like this: Errors('[dbo].[datasourceName]')

The intellisense should have replaced the name with quotes to begin with.

View solution in original post

7 REPLIES 7
Community Support
Community Support

Hi @dave-jorgensen,

 

When using a SharePoint connection, I do not get this error in Errors function. Would you please also test with other connectors to see if the issue is related only to SQL connection?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mona.

I don't use any sharepoint connections. The only connections I use is to sql databases hosted on azure. I'm not sure why you would try to reproduce using a sharepoint connection, not why you would ask me to test using a sharepoint connection. I'm trying to get it to work for a sql database connection.

 

Can you try and replicate the problem with a sql connection and let me know if you see the same results?

Any further information on sql as a datasource for the errors function?

It could be an issue with the way intellisense is substituting your selection. PowerApps folks have to look into that substitution issue. Can you try surrounding the datasource name with single quotes like this: Errors('[dbo].[datasourceName]')

The intellisense should have replaced the name with quotes to begin with.

View solution in original post

I tried adding the quotes. 

Errors function give the following error:

"the property expects text values, but this rule produces incompatible table values "

 

I'll add this as a bug.

"the property expects text values, but this rule produces incompatible table values " - This is not reported by the errors function. Where ever you are using the Errors Function that particular property is expecting text values. YOu can do First(Errors('data Source')).Message

Thanks Hemanth, you're right.

earlier suggestion of adding quotes works. 

I'll mark as answer (the adding the quotes) since that was the real solution to the problem of powerapps not adding sql datasource properly from intellisense.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (7,991)