cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Errors on form in powerapp

How do I get rid of these error messages? They don't show in Production, but they're just a nuisance when trying to navigate an actual problem. Doing data refresh and building a new page gives me the same issue.

1 ACCEPTED SOLUTION

Accepted Solutions
v-yutliu-msft
Community Support
Community Support

Hi @Anonymous ,

Firstly, did you set the formula that you showed to the form's Visible property?

If so, I think this is wrong.

The form's Visible property should be set to ture or false.

If you want to set a form's mode, I suggest you two ways:

1)Set the form's DefaultMode: FormMode.Edit

2)Set the screen's OnVisible/Button's OnSelect: EditForm(Form1)

 

Secondly, please check your connection's name and the form's data source.

Since all your data cards have error message, I think the data source may be invalid.

Please try to recreate the form.

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Anonymous
Not applicable

Hi @Anonymous 

 

Did you check the DataSource property of the EditForm. 

 

Thanks.

v-yutliu-msft
Community Support
Community Support

Hi @Anonymous ,

Firstly, did you set the formula that you showed to the form's Visible property?

If so, I think this is wrong.

The form's Visible property should be set to ture or false.

If you want to set a form's mode, I suggest you two ways:

1)Set the form's DefaultMode: FormMode.Edit

2)Set the screen's OnVisible/Button's OnSelect: EditForm(Form1)

 

Secondly, please check your connection's name and the form's data source.

Since all your data cards have error message, I think the data source may be invalid.

Please try to recreate the form.

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

@v-yutliu-msft Thank you. I didn't set that Visible property, but somehow that's what they got to and no matter what I did would correct them. I ended up needing to make some changes in the source list and then needed to refresh my sources about six times in order to see the changes come through. Then I only needed to remove and replace certain data cards. 

 

Anyways, all seems good now. Thanks for helping me troubleshoot!

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (2,567)