cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Bvandyke22
Helper III
Helper III

Excel Table not displaying data

Hi,

 

I created a table and when i use it as local version, the data populates my app as it should. If i upload it to OneDrive, the data no longer populates. I've even tried adding it as a new page in an excel book that is currently working for me and its still not working. Any Insight here?

I've made sure my Data Source Names match. Changed the name multiple times, and no luck. If i switch back to the offline version, it works perfectly. I've tried both uploading the current work book, and copy and pasting the table to a book i'm using. No luck with either. 

 

PowerApps recognizes the DataSouce, and clears all errors, but just gives a blank page. The table is a schedule and currently has a years worth of entries, however i've tried it with 2 entries or 365. no luck either way, unless its offline.

1 ACCEPTED SOLUTION

Accepted Solutions

It will eventually work after reconnecting restart the app and wait for some few seconds.

Your excel table is fine. If you have a Calculated column, remove them. You can also try on another table with small rows

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

View solution in original post

5 REPLIES 5
eka24
Super User III
Super User III

Is the excel table properly formatted as a Table, if so, Delete the excel connection in powerapps and reconnect it again.

To verify if properly formatted, it should have a powerappid column which is automatically generated.

If in doubt, show a screenshot of the ExcelTable

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

 

Ok, That may be the problem. I formatted as a table, but when i incorporate it, there is no powerapps id column. Do i need to manually add this or how can i verify the table is being properly formatted?

As I said earlier, Delete the the Table connection inside powerapps. Then reconnect again to Powerapps. If your are not sure of the formatting, give a screenshot of your Table

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

I've removed and recreated the data source multiple times, recreated the table all together. Renamed items, changed column names. I'm about lost at this point.

It will eventually work after reconnecting restart the app and wait for some few seconds.

Your excel table is fine. If you have a Calculated column, remove them. You can also try on another table with small rows

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Carousel April Dunnam Updated 768x460.jpg

Urdu Hindi D365 Bootcamp

Dont miss our very own April Dunnam’s The Developer Guide to the Galaxy! Find out what the Power Platform has to offer for the traditional developer.

Top Solution Authors
Top Kudoed Authors
Users online (1,893)