cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
maruthi216
Helper III
Helper III

FLOW Failing get Item ID

Hello,

 

Can someone help on this error.. of MS flow failing... from powerapps.

1 ACCEPTED SOLUTION

Accepted Solutions

Ok i got this.

 

On Button: Select property: submiform(sharepointform1);ABCFLOW.Run(Sharepointform1.lastsubmit.ID).

 

If i do this its working..

 

Thanks all for replies.

View solution in original post

7 REPLIES 7
Pstork1
Dual Super User III
Dual Super User III

Can you share the code in the OnSelect property under the two buttons?  It looks like you aren't passing the ID to the Flow.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

ONSELECT: SubmitForm(SharePointForm1);FLOW2019_3.Run(SharePointIntegration.SelectedListItemID)

Pstork1
Dual Super User III
Dual Super User III

Double check that the SelectedID values is actually what you are expecting it to be.  I've seen times in the past when something about that form gets off and the Selecteditem doesn't show up correctly.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Hello,

I even deleted the flows, buttons and added New, but still i am getting the same error in the flow.

 

I tried to add the flow at the form level and just submit form @ button level, but still same error.

 

I can delete the list and do that, but the problem will occur if i delete the Line item and again run the flow..

 

Any suggestions...?

 

Thanks.

Hi @maruthi216 ,

Maybe you could change the action's order.

For example, try this:

ONSELECT: FLOW2019_3.Run(SharePointIntegration.SelectedListItemID);SubmitForm(SharePointForm1)

Because the form's data will be invalid after the form has been submitted.

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I am getting same error. No change, its hung up at ID:1.

Ok i got this.

 

On Button: Select property: submiform(sharepointform1);ABCFLOW.Run(Sharepointform1.lastsubmit.ID).

 

If i do this its working..

 

Thanks all for replies.

View solution in original post

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,661)