cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
HSI
Level: Powered On

Failed PowerApps Custom API creation

Trying to follow the tutorial at https://docs.microsoft.com/en-us/azure/azure-functions/functions-powerapps-scenario. I am able to create and test the Azure Function, however, when I try to "Export to PowerApps + Flow" I receive the following error message and cannot continue.

 

Failed PowerApps Custom API creation. Error Details: Either 'OpenApiDefinition' or 'AppDefinitionUrl' must be specified, and only one should be specified

 

Swagger definition attached:

Swagger.PNG

 

1 ACCEPTED SOLUTION

Accepted Solutions
HSI
Level: Powered On

Re: Failed PowerApps Custom API creation

It appears to be an IE11 issue for me. I ran it in Chrome and it worked as advertised.

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: Failed PowerApps Custom API creation

Hi HSI,

 

The error message says that you should specify either OpenApiDefinition or AppDefinitionURL for your Swagger file.

 

Please check this documentation for a reference, this tutorial will introduce you how to create an OpenAPI definition for a function. Please take it for a reference:
https://docs.microsoft.com/en-us/azure/azure-functions/functions-openapi-definition

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
HSI
Level: Powered On

Re: Failed PowerApps Custom API creation

I have followed the tutorial to create the function at https://docs.microsoft.com/en-us/azure/azure-functions/functions-openapi-definition. That tutorial works and I included the OpenAPI definition that was created in my original post, however, the "Tutorial to Call a function from PowerApps" https://docs.microsoft.com/en-us/azure/azure-functions/functions-powerapps-scenario does not work.

 

Please advise.

skippy
Level: Power Up

Re: Failed PowerApps Custom API creation

The same issue occurs for me when following the tutorials. 

HSI
Level: Powered On

Re: Failed PowerApps Custom API creation

It appears to be an IE11 issue for me. I ran it in Chrome and it worked as advertised.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,019)