cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
mchien
Level: Powered On

'Failed during http send request' when re-adding Flow datasource

Since i modified my Flow, I had to re-add the datasource to get new parameters to show.

So I deleted the datasource, but when i try to get PowerApps to automatically re-connect the datasource, it gives shows this error

Untitled.png

Using Fiddler4, i get a 500 error:

{"error":{"code":"InternalServerError","message":"Encountered internal server error. The tracking Id is 'af278631-d529-4a14-b5ed-af6a2c51af5d'."}}

I'm not too sure what's going on 

7 REPLIES 7
mchien
Level: Powered On

Re: 'Failed during http send request' when re-adding Flow datasource

It turns out, my flow had a parameter set to "Apply for Each" block in Flow.

 

It didn't seem to like that.

michalkoziol
Level: Powered On

Re: 'Failed during http send request' when re-adding Flow datasource

so you simply deleted "aply to each"? i need this segment in the flow to loop over all sharepoint items

Srautiow
Level: Powered On

Re: 'Failed during http send request' when re-adding Flow datasource

I just ran into this issue when updating a flow of mine.
Surely the issue can't be that you are not able to use Apply to Each actions in a Flow when triggered via PowerApps.
There's no way for me to avoid using a Apply to Each action with a Send an HTTP Request to SharePoint inside the loop

PVosEska
Level: Powered On

Re: 'Failed during http send request' when re-adding Flow datasource

What browser might you be using? I had the same problem in FireFox. When i switched to Chrome it was fine though, i could re-add it again.

ANB
Level: Power Up

Re: 'Failed during http send request' when re-adding Flow datasource

Hello,

 

Even I faced the similar issue.  This might occur when the Flow is created by Person A and then Person A share the Flow to Person B and now Person B is co owner of Flow, however flow is still using the connection of person A.

 

If Person B wants to add the Flow to PowerApp, Person B have to make sure that all actions which is used into your Flow like Get my Profile, SharePoint etc. is using Person B's connection.

 

It worked for me...!!!

 

Thanks,

ANB

 

 

 

 

Srautiow
Level: Powered On

Re: 'Failed during http send request' when re-adding Flow datasource

Well as a bit of an update the previous flow that was throwing the error for me has now started working. In the sense that I could all of a sudden add it back to PowerApps.

I was using two different accounts so the point ANB brought up might have been relevant. But I also didnt change any connections between the error appearing and dissapearing so I dunno. Overall a frustrating experience, glad it started working, but I wish I had better tools to track the actual underlying issue. Too many issues are answered with "Have you tried rebuilding the flow from scratch"

 

Dawidvh
Level 10

Re: 'Failed during http send request' when re-adding Flow datasource

Hi @Srautiow 

 

I have seen this error before when there was something wrong with the schema in the flow response. I have also seen this when the schema has an array of Required properties.

 

Dawid van Heerden
Follow on Twitter: @davestechtips
Subscribe to YouTube: https://www.youtube.com/davestechtips?sub_confirmation=1
**If you found this reply helpful, please mark this as the answer to close the topic and make it easier to find for other people with similar questions.

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (4,935)