cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

Re: Failed to register the service

Hi @Anonymous 

I don't know if this is an ongoing issue. My recollection is that I just had to recreate the entire Flow and try again. I don't believe that I ever understood what was wrong with the Flow that would not register, so I cannot try to reproduce to test.

Frequent Visitor

Re: Failed to register the service

 Nope


@Anonymous wrote:

@jadm @NPBA_AT  @Anonymous  @NigelP  @IrhanC  Are we still have issues with this?

@Anonymous 



- all resolved - 

Highlighted
Post Prodigy
Post Prodigy

Re: Failed to register the service

HI @Anonymous 

 

I have had no problems recently.

 

Regards

 

Nigel

Highlighted
Helper II
Helper II

Re: Failed to register the service

Hi @Anonymous , @jadm 

I have just experienced this problem again. I have a quite complex Flow for an approval process that was all working and now it just won't start from my PowerApp. It started coming up with a runtime error "trigger is not enabled" which I have not been able to find any information about.

 

I then removed the Flow from my app and now I have the dreaded "Failed to Register Service" error when I try to register the Flow again.  

 

Please advise what steps I can take to try to fix this?  I see other posts here talking about the problem being with the auto generated JSON schema. Can anyone help me with looking at this?

 

Thanks,

Anne

Highlighted
Helper II
Helper II

Re: Failed to register the service

Hi @Anonymous  and @jadm ,

I have managed to register the Flow now. I tried the suggestion of exporting the Flow and then reimporting it again as an update, and that seemed to fix the problem.

 

Thanks,

Anne

View solution in original post

Highlighted
Advocate I
Advocate I

Re: Failed to register the service

We are having the same issues with registering our Flows here...  What I have found is if you have different connections, we have multiple people using their own connections while building, the service will not register.  Once the connections in Flow have been changed to person registering the Flow in PowerApps, everything registers correctly.

Exporting and re-importing a Flow will request access to a connection when you open the Flow up, hence re-establishing the connection to the logged in user.

Mannually - Make sure to change the connection in each step of the Flow to the person who is registering the Flow in PowerApps, save the Flow, refresh PowerApps, connect the Flow to the item in your PowerApp, everything should register correctly.

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (8,236)