cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NPBA_AT
Level 8

Re: Failed to register the service

Hi @TopShelf-MSFT 

I don't know if this is an ongoing issue. My recollection is that I just had to recreate the entire Flow and try again. I don't believe that I ever understood what was wrong with the Flow that would not register, so I cannot try to reproduce to test.

IrhanC
Level: Powered On

Re: Failed to register the service

 Nope


@TopShelf-MSFT wrote:

@jadm @NPBA_AT  @lobanyana  @NigelP  @IrhanC  Are we still have issues with this?

@TopShelf-MSFT 



- all resolved - 

NigelP
Level 8

Re: Failed to register the service

HI @TopShelf-MSFT 

 

I have had no problems recently.

 

Regards

 

Nigel

NPBA_AT
Level 8

Re: Failed to register the service

Hi @TopShelf-MSFT , @jadm 

I have just experienced this problem again. I have a quite complex Flow for an approval process that was all working and now it just won't start from my PowerApp. It started coming up with a runtime error "trigger is not enabled" which I have not been able to find any information about.

 

I then removed the Flow from my app and now I have the dreaded "Failed to Register Service" error when I try to register the Flow again.  

 

Please advise what steps I can take to try to fix this?  I see other posts here talking about the problem being with the auto generated JSON schema. Can anyone help me with looking at this?

 

Thanks,

Anne

NPBA_AT
Level 8

Re: Failed to register the service

Hi @TopShelf-MSFT  and @jadm ,

I have managed to register the Flow now. I tried the suggestion of exporting the Flow and then reimporting it again as an update, and that seemed to fix the problem.

 

Thanks,

Anne

View solution in original post

Highlighted
gmurnock
Level: Powered On

Re: Failed to register the service

We are having the same issues with registering our Flows here...  What I have found is if you have different connections, we have multiple people using their own connections while building, the service will not register.  Once the connections in Flow have been changed to person registering the Flow in PowerApps, everything registers correctly.

Exporting and re-importing a Flow will request access to a connection when you open the Flow up, hence re-establishing the connection to the logged in user.

Mannually - Make sure to change the connection in each step of the Flow to the person who is registering the Flow in PowerApps, save the Flow, refresh PowerApps, connect the Flow to the item in your PowerApp, everything should register correctly.

Helpful resources

Announcements
New Ranks and Rank Icons in April

'New Ranks and Rank Icons in April

Read the announcement for more information!

Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (8,207)