cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Failing to connect to MySQL server

Hello i am developing an app for my company and I need to connect to a MySQL server (its not the localhost) its a server Stored in the company clusters. I have downloaded and created a Gateway but when ever I try to connect to the MySQL 8 server using my credentials i get the error DMTS_EncryptClusterCredentialsErrorCode i cannot solve this problem it is really important

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: Failing to connect to MySQL server

Hi @laquino ,

Have you enabled your On-premises Data Gateway for PowerApps & Power Automate properly in your PC?

 

Please make sure you have enabled On-premises Data Gateway Client in your PC already. Also please check if you have configured your On-premises Data Gateway property based on the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/gateway-management

 

The user @KhanhTNguyen has faced similar issue with you, please check the response within the following thread:

https://powerusers.microsoft.com/t5/Building-Power-Apps/PowerApps-with-SQL-server-connection/td-p/16...

Please check if there is something issue with the network port in your MySQL On-premise data gateaway. You could consider re-install your On-premises Data Gateway, and run Network test, make sure the On-premises Data Gateway works well in your PC.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Failing to connect to MySQL server

@v-xida-msft  yes i have installed the gateway several times and it doesnt work i dont know if its a port problem or firewall, my company uses a web filter and i do not have all the permissions 

Community Support
Community Support

Re: Failing to connect to MySQL server

Hi @laquino ,

If you do not have enough permission to track the issue with your On-premises Data Gateway, you could consider ask your Administrator to check if the Network Port of the On-premises Data Gateway has been configured properly.

 

In addition, you could also consider submit an assisted support ticket for further help through the following link:

https://powerapps.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (5,652)