cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Goodpack
Frequent Visitor

Filters Stopped working

below is my filter added to my gallery screen. It  was working before, now its stopped showing up the result. Kindly help resolving it.

 

Here ApproverDetail is a collection and  when i check it, it is collecting the correct value.

 

Filter('SystemAccess Request',(RFTicketStatus.Value="L2 In Progress"&& RFSupervisorName=(First(ApproverDetail).Employee))||(RFTicketStatus.Value="L1 In Progress" && RFSupervisorName=(First(ApproverDetail).Employee)))

1 ACCEPTED SOLUTION

Accepted Solutions

@Goodpack ,

There is no real way I can tell you that, I can only try to get it working for you. One thing I have noticed recently is delegation issues when "nesting" lookups to other tables and complex fields in filters (hence the With() statement. So taking this a step further, if you ran this beforehand

UpdateContext(
   {
      vApprover:
      First(ApproverDetail).Employee 
   }
)

and you get a value in vApprover, then this filter should work

Filter(
   'SystemAccess Request',
   RFSupervisorName=vApprover &&
   (
      RFTicketStatus.Value="L2 In Progress" ||
      RFTicketStatus.Value="L1 In Progress"
   )
)

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

 

 

View solution in original post

7 REPLIES 7
WarrenBelz
Super User
Super User

Hi @Goodpack ,

You could try this

Filter(
   'SystemAccess Request',
   RFSupervisorName=First(ApproverDetail).Employee &&
   (
      RFTicketStatus.Value="L2 In Progress" ||
      RFTicketStatus.Value="L1 In Progress"
   )
)

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Still no luck,

When i remove the Collection part "First(ApproverDetail).Employee" and add a static value in the filter, it works.

But no luck with collection.

Also i get a delegation warning when i add the collection in filters.

 

 

 

Hi @Goodpack ,

Firstly, put a label on the screen with this as the Text

First(ApproverDetail).Employee

and make sure the value you want is there. If so, try this

With(
   {
      vApprover:
      First(ApproverDetail).Employee 
   },
   Filter(
      'SystemAccess Request',
      RFSupervisorName=vApprover &&
      (
         RFTicketStatus.Value="L2 In Progress" ||
         RFTicketStatus.Value="L1 In Progress"
      )
   )
)

I got this working on a collection, but not on a list (it has Delegation errors and returned no result)

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Didn't work.

I tried lot of workaround. Apparently Filter is not giving  any results for Collection.

But i am not understanding, why it stopped working suddenly as it was working perfectly fine since last 1 year.

@Goodpack ,

There is no real way I can tell you that, I can only try to get it working for you. One thing I have noticed recently is delegation issues when "nesting" lookups to other tables and complex fields in filters (hence the With() statement. So taking this a step further, if you ran this beforehand

UpdateContext(
   {
      vApprover:
      First(ApproverDetail).Employee 
   }
)

and you get a value in vApprover, then this filter should work

Filter(
   'SystemAccess Request',
   RFSupervisorName=vApprover &&
   (
      RFTicketStatus.Value="L2 In Progress" ||
      RFTicketStatus.Value="L1 In Progress"
   )
)

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

 

 

View solution in original post

Hi @Goodpack ,

Just checking if you got the result you were looking for on this thread. Happy to help further if not.

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Sorry for the delay,

 

The latest solution provided helped me to resolve the issue. Seems like Collections and Lists can't be used in same filter but using context helped . 

 

Thanks a lot of the help 🙂

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,219)