cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SimonKrutsch
Frequent Visitor

First Button Press on a ForAll(Patch()) takes time without any progress.

Dear Community,

 

thank you for reading this! I have a problem I can not get arround. I have a ForAll(Patch))-Process which on first time usage does not trigger immediately. It takes a couple of seconds, sometimes longer before the code gets processed. Subsequent uses (patches) fire directly and fast. What can be the Problem here?

Warten is a Variable for a Waiting Screen so that users do not push buttons etc. while the patch is active. That loading screen is on first time usage not visible for the first seconds.

 

Here is the Code:

 

Set(Warten;true);;Patch(Lehrkörper;
ForAll(
Filter(Gallery_Lehrkörper.AllItems;
(CountRows(ComboBox3.SelectedItems) > 0) || (CountRows(ComboBox3_1.SelectedItems) > 0)
) As _item;
If(CountRows(ComboBox3.SelectedItems) > 0;
{ID: _item.ID;
'Dozent 1': Concat(_item.ComboBox3.SelectedItems; Result);
'Ampel 1': 0
};
{ID: _item.ID;
'Dozent 2': Concat(_item.ComboBox3_1.SelectedItems; Result);
'Ampel 2': 0
}
)
)
);;Set(Warten;false)

0 REPLIES 0

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (47,068)