cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
maikeru
Helper I
Helper I

First row of Gallery doesn't show after PowerApps release update to 3.19075.21

Dear all,

 

My app was working fine until yesterday under 3.19074.24, but after I republished it today under 3.19075.21 (without any change... just added a blank space in App.OnStart), the first row of every Gallery doesn't display anymore.

After restoring the app under 3.19074.24 things are ok.

Please advise.

 

Best regards.
Michael

1 ACCEPTED SOLUTION

Accepted Solutions

@maikeru @Anonymous  Studio version 3.19075.25 has now been deployed to all regions. It contains a fix for the layout and rendering issues being reported. You will need save and re-publish your apps for the changes to take effect. Please remember it can take up to two minutes after publishing for the new version to become available for download. If any issues persist, please let us know! Thank-you for your patience.

View solution in original post

20 REPLIES 20
v-yutliu-msft
Community Support
Community Support

Hi @maikeru ,

I'm sorry for what you experienced.

I will report this problem to my product team.

If there is any improvement about this, I will reply here.

If your problem is very urgent, you could ask for help here:

https://powerapps.microsoft.com/en-us/support/

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hi 

 

I am on version  3.19075.20 (didnt find a version .21 on the playstore) and even I am facing the same problem here. The first item of every gallery is blank until it is loaded again or I click something.

 

@maikeru - How did you roll back to the previous version of powerapps app via play store? Please let me know.

 

Thanks,

AShep

dear @Anonymous 

 

I rolled back the application published on powerapps.com, not on the mobile client side.

 

Best regards.

 

Michael

Anonymous
Not applicable

Dear maikeru,

 

Sorry, I am a little confused here. Isn't the application version (which one develops on powerapps online ) different than the version of Powerapps itself?

If I understand correctly, you rolled back your app version on powerapps.com which had your development changes.

Was there an issue in the app that you have developed OR the powerapps version itself? Also, didn't rolling back undo your changes which were on the latest version?

 

Kindly clarify.

 

Thanks in advance,

AShep

@Anonymous 

To determine whether the issue was coming from PowerApps or my App, I rolled back my App to the latest point when PowerApps was still under 3.19074.24. This restored both my App former configuration and Powerapps.com former version. Once I confirmed the rollback and my app was running without issue, I republished it almost unchanged (I just entered a blank space somewhere in Apps.OnStart) under 3.19075.21. The issue appeared again.

Hope this clarifies.

Anonymous
Not applicable

Hi maikeru,

 

Yes, it clarifies. I checked with one of my colleagues who is running an older version of powerapps on her phone and the new app that I have published works there without any issue.

 

So, yes, this definitely looks to be an issue from the Powerapps side and hope it gets resolved soon.

Also, I am seeing this issue only on my mobile. The web version works fine with no issues even on the new release.

 

Did you see issue on both ends - mobile as well as web?

 

Thanks,

AShep

Thanks for the info.
Yes only mobile versions seem affected.
I have created a new (different) app from scratch today and the galleries are displaying correctly. I will try to recreate those galleries in my app to see if this helps. Will update.

@v-yutliu-msft 
After running further tests, I noticed that removing controllers referencing the Gallery in the child pages would (in some cases) help to solve the 1st row display issue. Typically my app goes from a gallery to child pages displaying further details of the selected item of the gallery using Gallery.Selected.[Name of the field].
This is in no way a solution, but perhaps it can give you some heads up to investigate the issue.

 

Thank you for your follow up and support!

@maikeru @Anonymous Can you please provide a session ID of an affected player session?  Also, what is the underlying data source that the gallery is connected to?  SQL?  SharePoint?  CDS?  etc.

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (2,070)