cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Flow Response Not Displaying in PowerApp

Hi all,

 

I have a small App I created to get stock market index quotes, and I connect to a Flow to get the data. The Flow runs fine. I can see the response:

 

Flow Output.jpg

 

I populate a Global variable to get the response using this code "Set(StockResponse,Stock_PowerAppButton.Run("Index"))". I then set the Text attribute of a Label to display one of the response values). But nothing is displaying. When I look at my Global Variable I can see it has the response schema, but no values. 

 

Global Variable.jpg

I did set up the Flow response values as "Numbers" rather than "Text". I wouldn't think that would be a problem.

1 ACCEPTED SOLUTION

Accepted Solutions
Dual Super User II
Dual Super User II

Re: Flow Response Not Displaying in PowerApp

In your last sentance you said you set the Flow response as numbers rather than text.  I'm suggesting you need to change that and then translate the text response to numbers after its returned.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

4 REPLIES 4
Highlighted
Dual Super User II
Dual Super User II

Re: Flow Response Not Displaying in PowerApp

If you look at the JSON output you can see that everything being returned is in quotes so its definately coming through as text not numbers.  You'll need to add a Value() function around the responses if you want to use them as numbers.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Frequent Visitor

Re: Flow Response Not Displaying in PowerApp

I saw that as well, which is only adding to my confusion as to why the labels are not showing the values.

Dual Super User II
Dual Super User II

Re: Flow Response Not Displaying in PowerApp

In your last sentance you said you set the Flow response as numbers rather than text.  I'm suggesting you need to change that and then translate the text response to numbers after its returned.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

Highlighted
Frequent Visitor

Re: Flow Response Not Displaying in PowerApp

So I initialize the variables in the Flow as "Float". In the "Respond to a PowerApp or flow" step I use the "Number" option. So I'm using Flow with the "out of the box" options.

 

But PowerApps only reads the data when the response is sent back as "Text". Seems like something isn't working as it's supposed to. 

 

Anyway, good suggestion. It worked when I recreated the output as strings.

Helpful resources

Announcements
Check this Out

Announcing

Class of 2020- Season 2

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (10,184)