cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AVTS
Post Patron
Post Patron

Flow error - Failed during HTTP send request

Team i am unable to add the flow in the button . Below is the error.

Flow error ,

 

AVTS_0-1623590657289.png

 

Flow Json response,

{
    "type""object",
    "properties": {
        "poNumber": {
            "type""string"
        },
        "company": {
            "type""string"
        },
        "changedOn": {
            "type""string"
        },
        "createdBy": {
            "type""string"
        },
        "purchaseOrg": {
            "type""string"
        },
        "vendor": {
            "type""string"
        },
        "tradingName": {},
        "poLines": {
            "type""array",
            "items": {
                "type""object",
                "properties": {
                    "poNumber": {
                        "type""string"
                    },
                    "lineNo": {
                        "type""string"
                    },
                    "material": {
                        "type""string"
                    },
                    "shortText": {
                        "type""string"
                    },
                    "materialGroup": {
                        "type""string"
                    },
                    "plant": {
                        "type""string"
                    },
                    "stoLocation": {
                        "type""string"
                    },
                    "moveType": {
                        "type""string"
                    },
                    "quantity": {
                        "type""string"
                    },
                    "bom": {
                        "type""string"
                    },
                    "poRcvdQty": {
                        "type""string"
                    },
                    "matDocNumber": {
                        "type""string"
                    },
                    "matDocYear": {
                        "type""string"
                    },
                    "matDocItem": {
                        "type""string"
                    },
                    "stoBin": {},
                    "changedOn": {
                        "type""string"
                    }
                },
                "required": [
                    "poNumber",
                    "lineNo",
                    "material",
                    "shortText",
                    "materialGroup",
                    "plant",
                    "stoLocation",
                    "moveType",
                    "quantity",
                    "bom",
                    "poRcvdQty",
                    "matDocNumber",
                    "matDocYear",
                    "matDocItem",
                    "stoBin",
                    "changedOn"
                ]
            }
        },
        "bapiRreturn": {
            "type""array"
        }
    }
}
 
Below is the flow screenshot.
 
AVTS_1-1623590753615.png

 

Flow test is not showing error. How to check the JSON error if any ? Please guide me.

1 ACCEPTED SOLUTION

Accepted Solutions
Pstork1
Dual Super User III
Dual Super User III

Check to make sure none of the fields listed in the JSON schema as required have null or empty values.  I've seen that cause this kind of error.  I usually do a filter array and a data select to filter out rows with empty values and select only the required columns for the return.  This can simplify troubleshooting.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

5 REPLIES 5
Pstork1
Dual Super User III
Dual Super User III

Check to make sure none of the fields listed in the JSON schema as required have null or empty values.  I've seen that cause this kind of error.  I usually do a filter array and a data select to filter out rows with empty values and select only the required columns for the return.  This can simplify troubleshooting.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

Thanks it helped. But i having another issue where this flow is created for Purchase order display in the datatable whereas i can see only header items and line items not showing fully. how to overcome this ? do you have any suggestion .

 

AVTS_0-1623592643129.png

 

POlines having all item data

Pstork1
Dual Super User III
Dual Super User III

I would need to know what the relationships are between the tables.  I assume there is one table that has the purchase orders themselves with a one to many relationship with the detail lines.  You need to retrieve the PO itself and then filter the detail lines to get the appropriate ones then return all that to Power Apps.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Hello Pstork.

Thanks for responding with you feedback.

It is one table where Purchase order header and line item available.

In flow test result all information is coming. But while in datatable line items shows in aggregated view.

 

Would be helpful if any samples on below would start this task.

filter the detail lines to get the appropriate ones then return all that to Power Apps.

 

 

Pstork1
Dual Super User III
Dual Super User III

I don't have any samples of that since its normally done as a one to many relationship instead of duplicating all the header information in every detail line. In the flow you could use a select to collect up all the columns that are the detail information to separate it from the header information.  But its going to be difficult to put it back together in a non aggregated fashion to return it to Power Apps.  And I'm not sure how I would attempt to filter the header information out of the detail lines to put it in a data table in Power Apps.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,977)