cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate III
Advocate III

Flow parameters not updating

Community

 

Not sure if anyone else is experiencing this. Today I updated parameters on a flow to include two more things to ask in PowerApps. When i jumped over to Powerapps, i noticed that my flow was not associated with the button, even though if you run the app it works.  So i reassociated it with the app, however the parameters are not there that I added. Wasn't an issue last thursday when I built the flow.

 

I also tried and noticed the same thing on another app.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate II
Advocate II

Re: Flow parameters not updating

I want to add that this method (removing the flow from the PowerApps "View -> Data Sources" menu and adding it back in the "Action -> Flows" menu) works but has error under some circumstances.  For instance, our flows are developed while logged in under a service account that differs from the accounts we use to develop PowerApps. It was causing us a "failed to register" error when atttempting to add the flow under the Actions tab.

 

To resolve, had to log into PowerApps using the same service account that was used to create the flow.

 

Also be sure to copy the text of your flow "Run()" command to paste back in to the new "Run()" text that will be inserted (otherwise your existing command text might get overwritten).

 

I also tried to use the PowerApps "Action -> Flows" menu to select the "Edit" option to edit the flow but again if logged in as a different user it will force you to enter credentials to rebuild all the connections.  If you log into PowerApps as that other Flow user account you do not have to enter new credentials.

View solution in original post

14 REPLIES 14
Highlighted
Advocate III
Advocate III

Re: Flow parameters not updating

I should add, i tried saving the app on .680, then doing the same thing but no luck

Highlighted
Advocate III
Advocate III

Re: Flow parameters not updating

i should this as well, now that i run the flow from the app it fails because of those missing parameters.

Highlighted
Community Support
Community Support

Re: Flow parameters not updating

Hi emckinney81,

 

Thanks for updating.

 

And glad to hear that you have solved this issue.


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate III
Advocate III

Re: Flow parameters not updating

Mabel, the problem isn't solved its still occuring. 

Highlighted
Advocate II
Advocate II

Re: Flow parameters not updating

Can someone respond? im having the same issue

Highlighted
Regular Visitor

Re: Flow parameters not updating

I am not sure if this is related, but I had a similar situation where I renamed a flow task, which did not refactor the parameters used by that step (Execute Stored Procedure). I had to recreate the flow then remap it in PowerApps because the new flow had a new GUID. This fixed my problem.

 

I am not suggesting you recreate your flow, but I am wondering if a PowerApps app keeps some sort of metadata information about the original flow including task parameters, etc., that do not allow it to "see" new parameters for a step.

Highlighted
Regular Visitor

Re: Flow parameters not updating

I am not sure if this is related, but I had a similar situation where I renamed a flow task, which did not refactor the parameters used by that step (Execute Stored Procedure). I had to recreate the flow then remap it in PowerApps because the new flow had a new GUID. This fixed my problem.

 

I am not suggesting you recreate your flow, but I am wondering if a PowerApps app keeps some sort of metadata information about the original flow including task parameters, etc., that do not allow it to "see" new parameters for a step.

Highlighted
Advocate III
Advocate III

Re: Flow parameters not updating

I basically did a save as on my current flow, then added the parameters i wanted and then deleted the old flow. Worked fine after that.

Highlighted
Advocate II
Advocate II

Re: Flow parameters not updating

cool ill try that thanks 🙂

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Find your favorite faces from the community presenting at the Power Platform Community Conference!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (7,184)