cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Flow running indefinitely to send an email

Hi,

 

An issue has appeared in my flow (it was working fine for the 60 first runs) and I can't figure out what is happening, I hope someone will be able to help me.

 

The flow is triggered when an item is created or modified in a SharePoint list, then it gets the modified item and it sends an email to the person assigned to this item. There is no action in my flow that could cause an infinite loop (no update item or anything else), it is just about sending an email notification.

 

I attached a screenshot of my flow and a screenshot when it is running indefinitely.

 

Thank you for your help !

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: Flow running indefinitely to send an email

It seems that my issue has been resolved by itself during the week-end : all the flows which were running for hours ended to be successful (after many hours or even 1 day). I don't know exactly why, maybe modifying concurrency control as suggested by @bloodoff worked with some delay.

 

Thank you all for your help !

View solution in original post

9 REPLIES 9
Highlighted
Dual Super User II
Dual Super User II

Re: Flow running indefinitely to send an email

Can you provide the formula you are using in your Condition?  That seems to be where the process is suspended.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Kudo Collector
Kudo Collector

Re: Flow running indefinitely to send an email

@Anonymous If nothing works you can try changing concurrency control of the trigger to this:

 

cc.png

PS Since that change is permanent you might want to make a copy of your current flow. Personally I've used Concurrency Control for When Created or Modified with success. I wish though MS had Create and Modified triggers separate.

Highlighted
Anonymous
Not applicable

Re: Flow running indefinitely to send an email

Thank you for your help @Pstork1 

 

The expression in my condition is : 

equals(triggerBody()?['Created'], triggerBody()?['Modified'])   is equal to   true
 
I don't understand how it could be the problem because the flow is going to the next step : it always chooses the right path according to whether it is a modified or created item
 
 
Highlighted
Anonymous
Not applicable

Re: Flow running indefinitely to send an email

Thank you for this idea @bloodoff, I just try that but it didn't work, I still have the exact same problem, the flow keeps on running for no reason... I can't figure out what is going wrong

 

Indeed I wish there were two different actions for modified and created items, it would have made things a lot easier... 

Highlighted
Dual Super User II
Dual Super User II

Re: Flow running indefinitely to send an email

Does the person the email is sent to every receive the email?  If not then check the settings on the send email and make sure they are correctly configured.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Anonymous
Not applicable

Re: Flow running indefinitely to send an email

Indeed people are not receiving emails anymore, but my flow was working at the beginning and people were receiving emails so I think the 'Send email notification' action is well configured.  I didn't change anything before the flow went down

 

 

Highlighted
Kudo Collector
Kudo Collector

Re: Flow running indefinitely to send an email

@Anonymous 1 thing I wanted to mention since you are using this condition:

equals(triggerBody()?['Created'], triggerBody()?['Modified'])

In my experience it doesn't give you solid results and consistency. Sometimes when you submit a new document Created and Modified time stamps can be 1 or 2 seconds off, I don't know why.  It's easy to check when you look at your trigger data in each run.

 

Highlighted
Anonymous
Not applicable

Re: Flow running indefinitely to send an email

@bloodoff Indeed sometimes the trigger action takes 1 or 2 seconds instead of 0, maybe it could have be part of the problem

Highlighted
Anonymous
Not applicable

Re: Flow running indefinitely to send an email

It seems that my issue has been resolved by itself during the week-end : all the flows which were running for hours ended to be successful (after many hours or even 1 day). I don't know exactly why, maybe modifying concurrency control as suggested by @bloodoff worked with some delay.

 

Thank you all for your help !

View solution in original post

Helpful resources

Announcements
secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Users online (4,694)