cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Flows are not getting added into the application while deploying it from Dev environment to Stage environment

Hi, Any suggestion would be really helpful. If anybody has encountered this issue earlier and solved it, it would be helpful to us. 

We are exporting our solution(Application and flows built inside solution folder) from Dev environment and uploading it to Stage environment.

But after exporting the package , we are not able to see the flows while we are trying to add those flows into the app.

Note: after deploying, we are re-establishing the connection in the flows and changing the status to 'On' as well.



Regards,

Nandan

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

HI @Anonymous ,

Do you want to import a solution from one Environment to another one?

 

Regarding the issue that you mentioned, I think this issue is related to Known limits related to Solution in Power Apps. Firstly, please make sure the flow is created from an existing canvas app already in a solution, rather than add the flow into this Solution from outside the Solution.

 

The app and flow will not currently be connected in the target environment post deployment. First associate valid connections with the flow and activate the flow. Then edit the app and re-associate the flow to the button.

 

More details about known limits related to Solution in Power Apps, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/common-data-service/solutions-overview#known-limitations

 

Regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

HI @Anonymous ,

Do you want to import a solution from one Environment to another one?

 

Regarding the issue that you mentioned, I think this issue is related to Known limits related to Solution in Power Apps. Firstly, please make sure the flow is created from an existing canvas app already in a solution, rather than add the flow into this Solution from outside the Solution.

 

The app and flow will not currently be connected in the target environment post deployment. First associate valid connections with the flow and activate the flow. Then edit the app and re-associate the flow to the button.

 

More details about known limits related to Solution in Power Apps, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/common-data-service/solutions-overview#known-limitations

 

Regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Frequent Visitor

I have a similar issue having exported a Canvas app to a Sandbox environment.

Without any amendments the flow fired (BUT the one in the default environment...)

 

Now I am here looking for a solution and the information on Associating anything flow related to the application again is being met by dead ends.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,535)