cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mryckman
Advocate IV
Advocate IV

(Form).LastSubmit date not populating

I have a form bound to an Azure SQL Database. There is a field "OfferDate", which is a Date type in SQL. Everything works as expected when a new record is created: the selected date saves to SQL properly and the form works normally.

 

But, if I access the form's "LastSubmit" property, the date value is empty. Note that LastSubmit does pickup everything else - including the primary key generated in the SQL db.

 

Can anybody help me understand what's going on here?

 

Thanks.

5 REPLIES 5
v-micsh-msft
Community Support
Community Support

Hi @mryckman,

 

Issue confirmed.

32.PNG

I will dig deeper and see if I could find any anthing helpful.

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
jeffreicher
Regular Visitor

I have the same issue.  Does anyone know when this issue will be fixed?  It's shocking that it has been 3 months and it still is not fixed.  Are we supposed to wait for 2 years before they work out all of the bugs before we deploy any apps that really matter to our businesses? 

I have the same issue.  I was trying to add a record to collection  after submitting the form to dbo.table and I originally had Collect(collection,Form1.LastSubmitted) in OnSuccess but the date field would not populate even though all the other fields did. The workaround was to put Collect(collection,First(Sort(dbo.table,ID,Descending))) in the OnSuccess dropdown.

larspeterson
Advocate II
Advocate II

This still doesn't appear to be fixed. I am using Azure SQL too.

 

I collected my dates via a context variable on a submit button. On success of the form I then appended to the collection and a variable via a patch statement.

 

I attached this to a forms OnSuccess for when it is a new form in case anyone needs a little guidance:

 

UpdateContext({_MySelectedItemInGallery:
  Patch(MyCollection,
    Defaults(MyCollection), 

    MyForm.LastSubmit, 

    {MyDate: _MyContextCollectedDate}
  )}
)

Currently experiencing the same issue which causes my form to display some empty fields after submitting, even though the previous values are stored in my SQL database.
Seems like [Form].LastSubmit still can not hold date values, even after 4 years.

Helpful resources

Announcements
October Events

Mark Your Calendars

So many events that are happening this month - don't miss out!

Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Top Solution Authors
Top Kudoed Authors
Users online (1,252)