cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Form Recognizer Connector

I created a flow using the Train Model connector. There isn't much for me to get wrong but when I try to run it I get the following error:

 

"Cognitive Services Form Recognizer 'v1.0-preview' APIs have been deprecated. Please upgrade to v2.0." 

 

I am not sure what needs to be upgraded or where. I didn't see anywhere to specify a version.

 

Anybody know?

3 REPLIES 3
Highlighted
Microsoft
Microsoft

Hi @jtwohig ,

 

Do you meet the error while the flow being triggered?

 

Although this looks like a Power Automate problem, I tried and found the below blog:

Form Recognizer API Reference - https://westus2.dev.cognitive.microsoft.com/docs/services/form-recognizer-api-v2-preview/operations/...

 

In this article, I noticed the Request URL syntax:

https://{endpoint}/formrecognizer/v2.0-preview/prebuilt/receipt/analyze[?includeTextDetails ]

 

Please check if this is where the error comes from.

 

Hope this helps.

 

Best regards,
Community Support Team _ Jeffer Ni
If this post helps, then please consider Accept it as the solution  to help the other members find it.
Highlighted

@v-jefferni 

 

That looks like it should work but it doesn't. 

 

I am trying to train a model so it says the URL should look like:

"https://{endpoint}/formrecognizer/v2.0/custom/models" and the example looks like:

"https://westus2.api.cognitive.microsoft.com/formrecognizer/v2.0/custom/models"

However, when I used that in the connection I get "Resource not found" which made sense to me because I don't know how it would know what resource to use if the resource name isn't there anywhere.

 

My Cognitive Services resource in Azure says that the endpoint is:

"https://XXXXX.cognitiveservices.azure.com/" (Where XXXXX is the name of my resource) so I tried:

"https://XXXXX.cognitiveservices.azure.com/formrecognizer/v2.0/custom/models" but I still got "Resource not found".

 

When I used the endpoint "https://XXXXX.cognitiveservices.azure.com/"  in the connection I got the message that I should be using version 2.0.

 

I wonder if the problem is that the Forms Recognizer Connector in Power Automate is only for version 1.0. However, I don't another connector that would be for version 2.0. 

Highlighted

Hi @jtwohig ,

 

Sorry for the delay. Have you resolved the issue?

 

If you have not found any solution, please refer to this official doc below:

https://docs.microsoft.com/en-us/connectors/formrecognizer/#deprecation-information

 

In this doc you could find that the Form Recognizer connector has been deprecated, and if you will have to migrate to V2, please refer to below doc:

https://docs.microsoft.com/en-us/azure/cognitive-services/form-recognizer/quickstarts/python-train-e...

 

Hope this helps.

 

Best regards,

Community Support Team _ Jeffer Ni
If this post helps, then please consider Accept it as the solution to help the other members find it.

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (12,467)