cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jaz915
New Member

Form attachments not updating on form view after submit - Sharepoint List

Hi all,

 

Fairly new to Powerapps and seem to be having a very frustrating problem that I am yet to find an answer for.

 

I have one data source which is a sharepoint list with 'attachments' enabled. I am using a gallery (Gallery2) to select a shop which in turn controls a form (Form2) that is displaying the 'attachment' field. Therefore allowing me to view, upload and delete attachments associated with a specific shop and the sharepoint list dataset.

 

 

Screen 1.PNGI then have a 'submit' button which it's 'OnSelect' property is set to 'Submitform(Form2)' used to save the change on the Sharepoint list.

 

This works as expected and intentionally stays in DisplayMode_Edit.

 

The problem I am having is that once a file is attached/removed and submitted the form does not display this change unless I select a different shop and then click back onto the shop of which I have just attached/removed the file. I thought that if I then add the 'Reset' function to my submit button it would resolve the issues - Onselect=SubmitForm(Form2);ResetForm(Form2) however this doesn't have the desired affect, I also tried 'resetting' the Gallery, again no luck.

 

I will be most greatful if someone can help with this!!! Alternatively if there is a way to set the default value of the gallery to 'No item to display' (as it appears on first load) this would also work as it would force the user to reselect the shop which I hope in turn would reflect the change.

 

I really hope that all makes sense!

 

 

 

 

 

 

5 REPLIES 5
Community Support
Community Support

Re: Form attachments not updating on form view after submit - Sharepoint List

Hi @Jaz915 ,

 

Do you mean when you remove the attachment's file, it can't be removed?

Do your Form's Item:Gallery2.Selected?

And Do your Form's OnSuccess's property is Back()?

Or could you please test with another browser to test?

I try to reproduce your issue with many ways but failed.

 

Hope this could be helpful.

 

Best Regards.

Yumia

Highlighted
Jaz915
New Member

Re: Form attachments not updating on form view after submit - Sharepoint List

Hi Yumia, @v-yuxima-msft 

 

Attachments can be removed and added successfully and the function works, however the form (form2) does not update it's view until a different shop is selected. For example:

 

I have successfully attached a document to the selected shop (Dunfermline Duloch F&E) however the form still says 'there is nothing attached' despite the datasouce (sharepoint list) also reflecting this change, i.e. within the data source a file is now attached to this shop location. The only I can get the form to show a file is now attached is to click on a different shop (Holywood) and then click back onto previous shop (Dunfermline Duloch F&E) where the file is now showing up. Please see attached images. I thought adding a 'resetform' property to my 'submit' button would refresh the view but it does not 😞

 

Yes, Form Item is set to Gallery2.Selected

 

Form 'OnSuccess' is currently set to 'false'.

 

I have tried on a different browser with no luck

 

Many thanks,

Jaz

 

DavidTansley
Regular Visitor

Re: Form attachments not updating on form view after submit - Sharepoint List

Hi @Jaz915 ,

 

Did you manage to resolve this issue?

 

I'm seeing exactly the same thing - loading an item into an edit form after clicking a link in a gallery. Add an attachment, submit form and then return to the gallery and click on the item - new attachment doesn't display.

 

If I click on another item in the gallery, load it into the form and then go back and load the original, the attachment displays.

If I add the attachment again, and then reload the item, the attachment displays.

If I look at the item in sharepoint at the initial add, the attachment is there.

 

It looks as though Refresh(datasource) doesn't pull through changes to the attachment unless you completely unload the item and load another one, then load the original again.

 

Can't see any way around it either.

 

Cheers,

 

Dave

mbrunet Advocate I
Advocate I

Re: Form attachments not updating on form view after submit - Sharepoint List

I believe I am also experiencing this. I hope @microsoft can look into this soon. I have a power app I was about to deploy now I cannot go fwd unless I have a resolution of workaround. Thanks

armn
New Member

Re: Form attachments not updating on form view after submit - Sharepoint List

I believe I am experiencing the same problem. @v-yuxima-msft any updates on this issue?

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

‘Better Together’ T-Shirt Contest – Winner Announced!

‘Better Together’ T-Shirt Contest – Winner Announced!

And the winner is...

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Power Platform 2020 release wave 1 plan

Power Platform 2020 release wave 1 plan

Features releasing from April 2020 through September 2020

Top Solution Authors
Top Kudoed Authors
Users online (7,090)