cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Gellai_Tamas
Helper I
Helper I

Form does not submit to SQL Server DB

Hey,

 

I have the following issue:

I created a form in PowerApps. When trying to submit data, it says that the field "ProductID" is required - though I added it.

 

powerapps_error_1.JPG

 

I'm suspicious that it is because I use a drop-down here and somehow I added the items wrongly. Although - based on the DB it should work well:

 

powerapps_error_2.JPG

 

I'm applying exactly the same method for the "Country" field (see 1. image, top left corner of the form) and there it works.

 

Is it a bug maybe? Or am I missing some necessary setting here?

 

Thanks,

Tamás

22 REPLIES 22

Are those issues solved now ?

Thanks,

There is this new information about NULL and BLANK in SQL Server but I haven't had time to check it out yet:

 

https://powerapps.microsoft.com/en-us/blog/new-feature-error-handling-and-writing-null-values-to-dat...

 

Gene_Carla
Frequent Visitor

Do you mind sharing how you created the dropdown menus and was able to connect to POWEAPPS?

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (54,847)