cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lumberjacklurch
Post Patron
Post Patron

Form not going into group

I'm hoping this is a simple one.  I created some labels, buttons, and a form.  I want to have them be in a group together, but when i hightlight them all and select Group, the form is outside of the group.  I'm sure I'm just not doing something right, but I'm having a hard time remembering what that is.

12 REPLIES 12
K-A-R-L
Solution Specialist
Solution Specialist

Hi @lumberjacklurch ,

Can you please make sure you select the Form before Grouping them.

 

Press and hold CTRL + Select Items (Label, Button, and Form)

SelectForm.jpg

 

Thanks,
K-A-R-L


If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@K-A-R-L

I did select it, but it is not in the group when PowerApps creates the it.

I have found the same thing is happening for me.

Thanks,
Mike L.
aorphan
Resolver I
Resolver I

Yes, we are also experiencing this same issue. This is a new issue that started happening recently. We have the "Enhanced group control" feature enabled. We have existing groups that contain forms. However when we attempt to add new groups, you cannot add forms. This breaks a lot of work we have put into our apps that use groups and is forcing us to use workarounds for the time being. Super frustrating!!

Anonymous
Not applicable

Also having this issue. I am selecting some controls + a form and when I group them, all the controls go into the group EXCEPT the form. 

I have existing groups with forms in them. If I copy and paste this group, the duplicated group contains all controls except the form.

 

Perhaps a bug was introduced in a recent PowerApps update?

Wondering if it may be related to the "Control Property Optimization" (preview) advanced setting being enabled by default now with no way to disable it.

aorphan
Resolver I
Resolver I

I have created a support ticket for this, ID: 119072324003012.

I spoke to Microsoft this morning and raised the issue, they are aware of it. The support engineer said they will hopefully have it fixed in a month...

Just to inform anyone interested, I just received another reply from support:

 

I’ve checked with my product team once again regarding the issue you’re experiencing with the enhanced group control.

 

I would like to inform you that, our team is currently working on a fix, that is the reason some of the behaviors with the ‘Form’ in all container controls are blocked(which means the ‘Form’ control from being added to an enhanced group control are blocked).

 

Once the issue is fixed, it will behave as expected. I will update you on this, once I get any response from the Product team.

Is there any update here as now I am seeing this is happening with DataTables as well.  This really creates additional work for managing positioning and visibility.

Thanks,
Mike L.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (30,720)