cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
audrieg
Power Automate
Power Automate

Frustration with Look-Up Valules - Please Help

I created my first Power App using the "List View Feature" on the new Modern List Experience last night. I have created many other Power Apps - but only from scratch - so I was expecting the List View Feature to be easier and faster. It was fun to try, and the only down side was that there is only a phone layout (no tablet layout)-but you can rotate it at least, Anyway, back to my problem:

 

After about an hour of working through adding fields and moving things around (formatting and such), I had my form where I needed it to be and shared it out to my org. During my testing (about 15 minutes later) the field containing look-up values busted.

 

Please note: The card field that busted is not 'really' a look-up field, it is a clone of the lookup in string format. To work around multi-select look-up constraints, I created column called FlatLookUp (single line text) in the list which is populated by a SharePoint Designer Workflow when the user changes a look-up column value (on item change). That FlatLookUp column just contains "the string" of the lookup. Since the lookup is multi-select, the FlatLookUp values look like this: first value; second value; third value.

 

What I mean by "busted" is this: I was using the FieldName.Value format in the data card, so that the words in the FlatLookUp column would show up on the form (I got that tip from the community-thank you). I even made a demo video for my customer with the form working beautifully (video available for MS technicians only), only showing a couple of minor "label fixes" to make). But then it busted (around 2AM PST).....the FlatLookUp started showing up with # signs before them and index numbers ...which was immediately followed by a few unlady-like words coming out of my mouth.

 

Does anyone know what might have happened to provoke this problem? Why did it work well, and then suddenly break during test (the Power Apps Desktop application was closed, and I was running it through the List View)?

 

Any advise would be so very appreciated, as this has me scratching my head in confusion. Don't worry about the unlady-like words, I am an extremely patient person under the hood (smiles).

 

Thank you again for your help,

Audrie

1 ACCEPTED SOLUTION

Accepted Solutions
audrieg
Power Automate
Power Automate

Not sure why I'm getting duplicate here...but I was able to resolve the issue which was on the Workflow side. The workflow updated the column incorrectly and Power Apps was only showing what it saw. So Power Apps still rocks and I can adjust the workflow to update as the Lookup values, comma dilimited to fix the issue!

 

Hope someone can at least use my workaround for the multi-select look-up values.

View solution in original post

1 REPLY 1
audrieg
Power Automate
Power Automate

Not sure why I'm getting duplicate here...but I was able to resolve the issue which was on the Workflow side. The workflow updated the column incorrectly and Power Apps was only showing what it saw. So Power Apps still rocks and I can adjust the workflow to update as the Lookup values, comma dilimited to fix the issue!

 

Hope someone can at least use my workaround for the multi-select look-up values.

View solution in original post

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,620)