cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

Galleries & Data Tables not loading data instantly

Hello,

i noticed a bug which occurs since the last powerapps update (i think - hasn't been this way one week ago).

In multiple of my apps, galleries or data tables do not load data when their item-property contains a search-function, unless you click/tab into the input field referenced in the search-function once (without entering anything).

Is anyone else experiencing this?

Thank you,
Christoph

PS: It would be very helpful if releases in What's New in Powerapps also had a release date besides the release number.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Champion
Community Champion

Re: Galleries & Data Tables not loading data instantly

Hi @Christoph_G, I think I had that issue a while back and then it went away.  Maybe now it is back.

If it is really back, then it may have to do with the changes happening around null values.

In many systems a null is not the same as an empty string, so the value of the control is maybe null before you click on it and an empty string once you click on it.

What happens if you use this as the search parameter?

Coalesce(MyTextInput.Text, "")

View solution in original post

2 REPLIES 2
Highlighted
Community Champion
Community Champion

Re: Galleries & Data Tables not loading data instantly

Hi @Christoph_G, I think I had that issue a while back and then it went away.  Maybe now it is back.

If it is really back, then it may have to do with the changes happening around null values.

In many systems a null is not the same as an empty string, so the value of the control is maybe null before you click on it and an empty string once you click on it.

What happens if you use this as the search parameter?

Coalesce(MyTextInput.Text, "")

View solution in original post

Highlighted
Advocate II
Advocate II

Re: Galleries & Data Tables not loading data instantly

Hello,

 

I am facing the exact same issue. A page would open but sometimes the galleries would not load any data from my Azure SQL datatables, If I refresh the datasource, It would load. 

 

This is a very inconsistant bahaviour. Did someone else face this aswell? What can be a solution to this?

 

Nouman

Helpful resources

Announcements
Ignite

Microsoft Ignite

This will be a conference that you do not want to miss!

secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (4,102)