cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
VisibleFilm
Helper I
Helper I

Gallery Form not seeing new fields added to SharePoint list

Hi all, I'm working on a gallery form that was created by a coworker.  It's datasource is connected to a SharePoint list - I've added new fields to the SharePoint list that I would like to add to the form, but I do not seem to be able to access the new fields when I click on "Edit Fields", even though I've refereshed the data source several times.  Is it not possible to see fields added to a SP list after the gallery form has been created?

1 ACCEPTED SOLUTION

Accepted Solutions

Thanks Russel!  Turns out it was just a timing issue - I walked away from the machine for 20 minutes, did another refresh of the data source and was able to see the fields.  Thanks again for your response.

View solution in original post

3 REPLIES 3
RusselThomas
Microsoft
Microsoft

Hi @VisibleFilm ,

 

You certainly can add fields to the source after connecting your PowerApp to it, and usually a simple refresh of the connector/data source will make the new fields available to you.

I have noticed that Data Grids are sometimes a little temperamental when you mess with their source and I sometimes have to delete and recreate them, but generally this works fine with other controls like Galleries.

 

There are a couple of things you can try to see if the new fields are there even if the Gallery isn't showing them;

Try collecting the gallery and then viewing the collection.

ClearCollect(collectColumns, SPOList)  //view using the View, Collections menu

Create a Text label and set it's Text: property to SPOList. and see whether the new columns appear in the prompt list after the period.

 

Create a blank app and add a new Gallery connected to the source to see if the fields appear there.

If they do, add another Gallery to the current app and see if they appear.

 

Lastly, make sure your gallery is connected directly to the source and not a collection - if it's connected to a collection you may need to refresh the collection as well before the fields become available to the gallery.

 

Kind regards,

 

RT

Thanks Russel!  Turns out it was just a timing issue - I walked away from the machine for 20 minutes, did another refresh of the data source and was able to see the fields.  Thanks again for your response.

View solution in original post

v-xida-msft
Community Support
Community Support

Hi @VisibleFilm ,

Have you solved your problam?

If you solved your problem, please go ahead to click "Accept as Solution" to identify this thread has been solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,402)